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INTRODUCTION
For biomedical research, super-resolution microscopy is a prom-
ising tool developed in recent years, allowing optical imaging 
beyond the diffraction limit of light, for up to molecular-scale 
resolution inside cells. The significance of this group of imag-
ing modalities is underlined by the Nobel Prize in Chemistry 
in 2014 ‘for the development of super-resolved fluorescence 
microscopy’. Super-resolution has been achieved by a variety of 
imaging modalities, most notably nonlinear structured illumina-
tion microscopy (SIM)1, stimulated emission depletion (STED) 
microscopy2, (fluorescent) photo-activated localization micros-
copy ((f)PALM)3,4 and (direct) stochastic optical reconstruction 
microscopy ((d)STORM)5,6. All these techniques achieve image 
resolution beyond the diffraction limit by controlling the state 
of fluorophores such that only a small subset of them are detect-
able at any given time. However, super-resolution approaches can 
be generally divided into the following two groups according to 
the specific mechanism for controlling the fluorophore state7: 
(i) illumination-pattern-based (SIM and STED) and (ii) single- 
molecule-localization-based (PALM and STORM) methods. All 
these super-resolution methods have been successfully used to 
reveal biological insights8–12, but each has its own advantages 
and difficulties. A practical advantage of both illumination-based 
methods is that they do not require specific fluorophores, which 
makes these techniques straightforward to use for biologists with 
conventional samples. However, instrumental implementations 
are typically more complex and intricate. By contrast, the branch 
of localization-based techniques uses stochastic blinking of spe-
cific fluorescent probes. This blinking permits them to be observed 
one at a time so that their spatial coordinates can be localized with 
subdiffraction precision13. Typically, this blinking is an intrinsic 
property of fluorescent proteins (PALM) or specific organic dyes 
(STORM), which can be provoked by specific excitation schemes 
and buffer conditions14,15. Although instrumentation is typically  

simpler for localization-based as compared with illumination-
based modalities, the complexity lies in achieving suitable blink-
ing behavior of the dyes. Troubleshooting often means testing a 
number of parameters such as the choice of dye, labeling den-
sity, buffer conditions and excitation illumination, making the 
blinking a hard-to-control phenomenon. In fact, the choice of 
‘well-behaving’ probes is limited, and further development of 
substantially improved probes is complex and time-consuming. 
Moreover, because of the limited choice of probes with appropri-
ate blinking kinetics, photon rates and excitation conditions, mul-
tiplexing is still difficult to implement. Furthermore, the complex 
photophysics of the probes impedes the predictability of blinking 
events so that quantitative image interpretation is error-prone. 
Last, owing to limited photon rates and bleaching, optimal locali-
zation precision and spatial sampling are still not achieved—the 
two major factors in resolution16. Although many biological ques-
tions could be addressed with the aforementioned techniques8–12, 
researchers are still struggling with these complications to truly 
exploit the power of super-resolution microscopy.

A different route to single-molecule localization microscopy 
is PAINT17. Here, instead of labeling target molecules with fixed 
fluorophores, freely diffusing dyes17 or dye-labeled ligands (as in 
uPAINT)18 target molecules of interest by permanent or transient 
binding. PAINT is straightforward to implement and does not 
require special experimental conditions to obtain photoswitch-
ing, as long as probes are able to diffuse and reach their target 
molecules. However, PAINT’s original implementation makes it 
difficult to specifically label a larger variety of biomolecules, as 
interactions are mainly limited to hydrophobic interactions or 
electrostatic coupling and are thus difficult to program.

DNA nanotechnology represents a promising tool for utiliz-
ing the advantages of the PAINT concept and establishing a pro-
grammable target–probe interaction system at the same time. 
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Super-resolution techniques have begun to transform biological and biomedical research by allowing researchers to observe 
structures well below the classic diffraction limit of light. DNA points accumulation for imaging in nanoscale topography (DNA-
PAINT) offers an easy-to-implement approach to localization-based super-resolution microscopy, owing to the use of DNA probes. 
In DNA-PAINT, transient binding of short dye-labeled (‘imager’) oligonucleotides to their complementary target (‘docking’) strands 
creates the necessary ‘blinking’ to enable stochastic super-resolution microscopy. Using the programmability and specificity of DNA 
molecules as imaging and labeling probes allows researchers to decouple blinking from dye photophysics, alleviating limitations 
of current super-resolution techniques, making them compatible with virtually any single-molecule-compatible dye. Recent 
developments in DNA-PAINT have enabled spectrally unlimited multiplexing, precise molecule counting and ultra-high, molecular-
scale (sub-5-nm) spatial resolution, reaching ~1-nm localization precision. DNA-PAINT can be applied to a multitude of in vitro 
and cellular applications by linking docking strands to antibodies. Here, we present a protocol for the key aspects of the DNA-
PAINT framework for both novice and expert users. This protocol describes the creation of DNA origami test samples, in situ sample 
preparation, multiplexed data acquisition, data simulation, super-resolution image reconstruction and post-processing such as 
drift correction, molecule counting (qPAINT) and particle averaging. Moreover, we provide an integrated software package, named 
Picasso, for the computational steps involved. The protocol is designed to be modular, so that individual components can be chosen 
and implemented per requirements of a specific application. The procedure can be completed in 1–2 d. 
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Specifically, DNA-based PAINT (DNA-PAINT) has been devel-
oped as a straightforward approach to overcome some limitations 
of current localization-based super-resolution techniques19–24. 
Similar to the original PAINT concept, DNA-PAINT decouples 
blinking from dye photophysics, but it also adds the program-
mability and specificity of using DNA molecules as imaging and 
labeling probes. A DNA-PAINT system, illustrated in Figure 1a, 
consists of the following two components: a docking strand and 
an imager strand. These are short, complementary single-stranded 
DNA oligomers, usually 8–10 nucleotides long. Although the 
docking strand is fixed to a biological target of interest (e.g., using 
standard immunolabeling approaches with DNA-conjugated 
antibodies targeting proteins of interest25 or direct hybridiza-
tion of docking strands to DNA or RNA molecules), the imager 
strand is conjugated to an organic dye and diffuses freely in the 
imaging buffer. Generally, imager strands appear undetectable 
in the camera because they diffuse over numerous camera pixels 
during the duration of a single frame. However, owing to their 
complementary sequence, imager strands can transiently bind 
to docking strands. During the bound state, imager strands are 
fixed at the same place for an extended amount of time, allowing 
the camera to accumulate enough photons from the dye to be 
detected. The binding duration depends solely on the stability of 
the formed DNA duplex, and can hence be programmed at will 
(e.g., by modulating strand length, GC content, temperature or 
salinity of the imaging buffer). On the other hand, the frequency 
of binding events is tunable by the influx rate of imager strands 

(e.g., by modulating either the concentration of imager strands 
in the buffer or the association constant). As a result, the user has 
fine control over the blinking kinetics, which is independent of 
dye properties or illumination specifics. To date, DNA-PAINT 
has been used to resolve nanometer-scale structures of DNA ori-
gami (Fig. 1b), as well as those of cellular proteins, by conjugating 
docking strands to antibodies (Fig. 1c–e).

Advantages and limitations of the method
The properties of DNA-PAINT result in several improvements 
over more traditional super-resolution approaches. First, the 
use of DNA-based imaging probes enables high multiplexing by 
Exchange-PAINT20 that is restricted only by the number of orthog-
onal DNA sequences, as compared with the spectrally distinct 
dyes used in classic multiplexing experiments. Figure 2 illustrates 
the concept, procedure and results of Exchange-PAINT experi-
ments in vitro and in situ. When tagging biological targets with 
orthogonal docking strand sequences, they can be probed sequen-
tially by the respective complementary imager strands (Fig. 2a).  
Specifically, after one DNA-PAINT image has been acquired, the 
buffer can be exchanged to introduce a different imager strand 
species. Repeated imaging, washing and reintroduction of new 
imager strand species then allows researchers to create a multi-
plexed image of many biological targets. Although we have thus 
far demonstrated nine-target super-resolution imaging25, multi-
plexing could reach thousands of species, as the only limitation is 
the orthogonality of DNA-PAINT sequences.
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Figure 1 | DNA-PAINT. (a) DNA-PAINT concept. Transient binding of dye-labeled DNA strands (imagers) to their complementary target sequence (docking  
site) attached to a molecule of interest. The transient binding of imager strands is detected as ‘blinking’, illustrated by the intensity versus time trace.  
(b) Diffraction-limited (left) and super-resolved DNA-PAINT images (right) of DNA origami nanostructures. Each structure consists of 12 docking strands  
that are arranged in a 20-nm grid (scheme in lower right corner). (c) In situ protein-labeling strategy for DNA-PAINT using primary and DNA-conjugated 
secondary antibodies. (d) Overlay of a diffraction-limited α-tubulin image (top left) with a super-resolved DNA-PAINT image (bottom right). (e) Close-ups of the  
highlighted area in d, comparing diffraction-limited image (left) with DNA-PAINT super-resolved image (right). Scale bars, 100 nm (b), 2 µm (d), 500 nm (e).
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Second, the predictability and tunability of DNA binding and 
unbinding events, combined with effectively nonexistent bleach-
ing, allow for accurate quantitative image interpretation (i.e., 
counting of single molecules in an integer manner), implemented 
in quantitative PAINT (qPAINT)22. Figure 3 depicts the qPAINT 
concept, procedure and results. A more detailed description of 
the method will be given below.

Third, DNA-PAINT simplifies the selection of suitable dyes 
for imaging, as the parameter space is reduced from rather com-
plex photophysical properties (e.g., switching behavior) to basi-
cally a single parameter—the photon budget. This also means 
that DNA-PAINT can use a large pool of existing fluorophores 
that were previously not applicable to localization-based super- 
resolution microscopy.

Finally, by programming the binding duration, an extremely 
high number of photons can be detected from a single binding 
(or blink) event, enabling optimal localization precision. The 
only limitations regarding the achievable photon budget are 
experimental time and photobleaching during a single bind-
ing event. However, the latter can be greatly reduced by specific 
imaging buffer compositions, such as oxygen-scavenging systems  

and triplet-state quenchers26–28. Even if bleaching of individ-
ual dyes does occur, it has only a minimal detrimental effect 
overall, because of the practically infinite supply of replenish-
able ‘fresh’ imager strands from solution. All things considered,  
photobleaching—which is a considerable complication for all 
other super-resolution techniques—is eliminated as a restric-
tion on achieving optimal sampling of the biological structure 
under investigation. Such optimized experimental conditions 
for high localization precision, combined with intricate drift 
correction methods, enable imaging at thus far unprecedented 
resolution in optical microscopy, for the first time enabling true 
molecular-scale resolution23, which, to our knowledge, has not 
been achieved using any other super-resolution method. Example 
results of images with localization precisions of ~1 nm, yield-
ing resolution better than 5 nm, and intermediate results of the 
applied drift correction are shown in Figure 4. To achieve these 
results, a large number of DNA origami structures were used as 
drift markers, considering first the whole structure, followed by 
the use of individual DNA-PAINT binding sites as fiducials. To 
eventually translate the in vitro ultra-resolution achievements to 
in situ samples such as fixed cells, a key challenge is the labeling 
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Figure 2 | Exchange-PAINT. (a) Schematic representation of sequential Exchange-PAINT imaging of multiple targets with orthogonal sequences using the same 
fluorophore. Left to right: P1* imager strands are in solution and interact with their complementary target sequence, P1. After the first acquisition round, 
the P1* imager strands are washed away and P2* imagers are introduced to image the next target. This is then repeated for the remaining target cycles, and 
pseudocolors are assigned for each respective imaging round. Last, all rounds are aligned and overlaid to form the final multiplexed Exchange-PAINT image 
of n targets. (b) Fluid exchange chamber for in vitro samples (e.g., for DNA origami imaging). Liquid is introduced by pipetting into the inlet. The outlet is 
attached to a syringe with a flexible tube to remove the liquid. (c) Fluid exchange chamber for in situ samples (i.e., used for in situ cellular imaging). Two 
tubes with syringes are connected to an 8-well chambered cover glass to facilitate fluid exchange. (d) Two rounds (‘colors’) Exchange-PAINT image of a frame-
like DNA origami structure carrying two orthogonal docking strand species (red and cyan; see also f, for design schematics). (e) Pseudocolor image after 
alignment of the imaging rounds using Picasso’s automated align function. (f) Top: DNA origami design. Bottom: Close-up (white box from e) of one frame-like 
structure. The distance between red and blue handles is ~5 nm. (g) In situ Exchange-PAINT image of protein targets a-tubulin (red) and Tom20 (cyan) with 
two primary and DNA-conjugated secondary antibody sandwiches. Inset: Images of one alignment marker (gold nanoparticle) in each Exchange-PAINT round 
without channel alignment (top), after Picasso’s automated cross-correlation analysis (middle) and after manually selecting the particle as an alignment 
fiducial (bottom). Scale bars, 100 nm (d, e), 20 nm (f), 2 µm (g), 300 nm (g, insets).
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probe size. The size of the labeling probes introduces a linkage 
error and effectively limits the labeling density (because of sterical 
hindrance). Both these effects finally limit the achievable resolu-
tion. One way to address these issues in cells could be the use of 
smaller labeling agents such as nanobodies29 or aptamers30, rather 
than antibodies.

Although DNA-PAINT offers several advantages over tradi-
tional super-resolution techniques, as discussed above, we also 
note that there are currently limitations. One disadvantage is the 
fact that ‘imager’ strands are nonfluorogenic, with the following 
two implications: first, DNA-PAINT is limited to optical section-
ing techniques such as total internal reflection (TIR), oblique31 
or light-sheet32 illumination because of elevated background 
fluorescence originating from unbound imager strands. Second, 
the nonfluorogenic nature of imager strands furthermore sets 
an upper limit to the achievable image acquisition speed as com-
pared with those of STED, PALM, STORM or SIM. Furthermore, 
DNA-PAINT applications are currently limited to fixed speci-
mens. Live-cell imaging could be more difficult to achieve as  
compared with the aforementioned techniques, because of the 
complexity of infusing dye-labeled nucleic acid strands into liv-
ing cells and the unforeseen consequences of introducing nucleic 
acids in general. However, we note that DNA-PAINT applications 
to molecules on cell surfaces such as membrane-bound receptors 
should be feasible even for living cells.

All in all, the DNA-PAINT imaging framework greatly reduces 
many technical difficulties of localization-based super-resolution 
microscopy and opens up possibilities for new technical devel-
opment and biological applications. It will therefore allow many 
research groups to address their biological question with much 
greater efficiency. To ease the adoption of DNA-PAINT for novice 
and expert researchers in the super-resolution field, this proto-
col details the involved procedures and provides an integrated  
software package, named Picasso, which is specifically designed 
for DNA-PAINT applications. Except for data acquisition, Picasso 
can handle all computational efforts required in this protocol, 
including in silico data simulation, DNA origami design, and 
basic and advanced functionality for localization-based super- 
resolution microscopy.

Overview of the main procedures
The overarching goal of this protocol is to enable both novices 
and expert users to quickly obtain high-quality DNA-, Exchange-
PAINT and qPAINT imaging data in silico, in vitro and in situ, 
without prior expertise in super-resolution microscopy. Here, we 
are using the term in vitro for DNA-PAINT studies with DNA ori-
gami structures on BSA/biotin/streptavidin-coated glass slides. By 
contrast, in situ is used to describe experiments involving fixed-cell 
samples. The protocol is based on several studies19,20,22,23,25 and is 
arranged into four major sections, as illustrated in Figure 5: sample 
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Figure 3 | qPAINT. (a) Design schematics for two DNA origami structures with 12 target sites spaced 20 nm apart (top, black-dotted box) and 42 binding sites 
spaced 10 nm apart (bottom, gray-dotted box), respectively. (b) DNA origami structures with 12 binding sites (top) exhibit fewer binding (blinking) events 
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grids, respectively. (c) Mean dark times τd1 and τd2 are obtained by fitting the cumulative distribution function of the dark times. (d) To measure binding 
sites for a structure of interest, DNA origami nanostructures are used to calibrate the influx rate (here displayed as the number of blinks per frame). Visual 
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qPAINT-predicted binding sites after calibration shows good agreement. (f) Visual comparison of 10-nm-grid DNA origami with predicted binding sites via 
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preparation (in vitro and in situ), data acquisition, image recon-
struction and image post-processing. For sa mple preparation, 
we describe the following two procedures: in vitro imaging (i.e., 
of DNA origami nanostructures) (Steps 1–18; Box 1) and in situ 

imaging (i.e., of cell samples) (Steps 19–33). Although not covered 
in this protocol, the procedures could be adjusted for DNA-PAINT 
imaging in tissue or whole organisms. Subsequently, we explain 
data acquisition (Steps 34–49), including a detailed procedure  
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Figure 4 | ‘Ultra-resolution’ with DNA-PAINT. (a) Workflow for ultra-resolution imaging with advanced drift correction and particle averaging. (b) Multistage 
drift correction with Picasso. Top: 20-nm-grid DNA origami structures used as reference structures and drift markers. Bottom: DNA origami target structure 
(designed to display the letters ‘MPI’ (upside down) with 5-nm ‘docking strand resolution’) present in the same sample as the 20-nm origami. In the first 
drift correction stage, an RCC procedure is applied to the whole field of view (image column after RCC arrow shows results). The second step uses Picasso’s  
semiautomated particle pick function (picked structure visualized by yellow circle) to select 1,675 DNA origami structures as fiducials for drift correction 
(drift for all structures is globally averaged and subtracted from the localization data). The result for this step is depicted in the third column. The third and 
last iteration uses the individual binding sites of the 20-nm grid for drift correction. Here, 29,157 binding sites were used as fiducial markers. The resulting 
image for the MPI target structures shows clearly resolved single binding sites spaced 5 nm apart. (c) Selection of two MPI origami after drift correction. 
Localization clusters of individual DNA-PAINT binding sites with a distance of ~5 nm are well resolved and circular, indicating that the residual drift is 
minimal and rotationally invariant. (d) Selection of two DNA origami, designed to show the letters ‘LMU’, from a different sample than in b,c,e, but after an 
analogous drift correction as shown in b. The images demonstrate minimal residual drift similar to that of the MPI structures shown in c. (e) Average image 
of 295 DNA origami with the letters ‘MPI’. The mean number of localizations in individual images is 3,485 ± 1,197. All DNA-PAINT binding sites are visible, 
even though individual images miss binding sites because of incomplete strand incorporation, as seen in c. (f) Average image of 215 DNA origami with the 
letters ‘LMU’. The mean number of localizations in the individual images is 2,323 ± 436. Scale bars, 10 nm (c–f). 
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to achieve very high spatial resolution (<5 nm) with DNA-PAINT, 
which requires particular care in sample preparation and data 
acquisition (Box 2). Furthermore, we lay out the procedure to 
simulate typical DNA-PAINT data in silico for test and optimiza-
tion purposes (Box 3). Then, image reconstruction is explained 
in two steps: fitting of single-molecule spots and subsequent ren-
dering of the super-resolution image (Steps 50–58). Finally, we 
describe multiple procedures for post-processing such as drift 
correction (Steps 59 and 60), selection of regions of interest (Steps 
61–68), filtering of localizations (Step 69A), quantitative imaging 
with qPAINT (Step 69B and C), particle averaging (Step 69D) and 
channel alignment for multiplexed images (Step 69E). Additional 

steps required for multiplexed imaging with Exchange-PAINT are 
described as optional steps in the respective sections.

One of the defining components of this protocol for DNA-
PAINT is an integrated software package called Picasso, which ena-
bles researchers to quickly obtain meaningful reconstructed image 
results without the need of additional third-party software tools.

The Picasso software package
Like similar localization-based super-resolution methods, DNA-
PAINT requires intricate data analysis. For that matter, we provide 
an integrated software package named ‘Picasso’ (free to download 
from http://www.jungmannlab.org). Although Picasso is suitable 
for any localization microscopy technique, it provides specific 
support for DNA-PAINT applications, e.g., qPAINT. All compu-
tational steps described in this protocol can be performed with 
Picasso. This includes designing of DNA origami structures and 
simulating typical DNA-PAINT data. After installation, Picasso is 
available as several stand-alone (but interlinked) modular compo-
nents with graphical user interfaces. The components are named 
‘Design’, ‘Simulate’, ‘Localize’, ‘Filter’, ‘Render’ and ‘Average’. The 
‘Design’ component allows the user to visually design rectan-
gular 2D DNA origami structures, which we call Rothemund’s 
rectangular origami (RRO)33, with DNA-PAINT handles. For 
that matter, ‘Design’ autogenerates order lists and pipetting 
instructions. With ‘Simulate’, the user may generate typical 
DNA-PAINT raw data from in silico simulations. After data have 
been acquired or simulated, the ‘Localize’ component allows the 
user to identify and fit the coordinates of single-molecule spots.  
‘Picasso: Filter’ offers a convenient tool to inspect the localization 
list, plot histograms of localization properties and filter locali-
zations with undesired properties. Super-resolution images can 
be rendered and inspected with the Picasso component ‘Render’. 
‘Picasso: Render’ also offers various post-processing func-
tions such as advanced drift correction and quantitative image 
evaluation by qPAINT. Last, the ‘Average’ module provides the 
functionality to perform particle averaging (i.e., rotational and 
translational alignment) of multiple images of the same structure. 
Analogous to single-particle reconstruction in the electron micro-
scopy field, this procedure helps to improve the signal-to-noise 
ratio of images. Overviews of the graphical user interfaces for the 
‘Design’, ‘Simulate’, ‘Localize’, ‘Render’ and ‘Filter’ components are 
shown in Supplementary Figures 1–5.

Although in principle a cross-platform development, we 
currently supply a one-click installer of Picasso for Microsoft 
Windows 64-bit operating systems. This single executable  
setup file can be downloaded from our website at http://www.
jungmannlab.org. Picasso is developed in Python, and the source 
code is available at https://github.com/jungmannlab/picasso.

Design and preparation of DNA origami structures
As DNA-PAINT makes use of the programmability of (transient) 
DNA strand hybridization to enable super-resolution imaging, 
DNA-based objects are convenient in vitro test targets for imaging. 
Nucleic acids can serve as powerful building blocks for nanom-
eter-scale structures based on sequence-guided self-assembly, 
which is the foundation of structural DNA nanotechnology34,35. 
DNA origami are complex, self-assembled, 2D or 3D struc-
tures created by annealing DNA strands of specifically designed 
sequences33. In DNA origami, a long single-stranded DNA 
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Figure 5 | DNA-PAINT protocol workflow. Starting with sample preparation, 
the user can perform either in vitro or in situ experiments. Next, data 
acquisition is performed (parameters for ‘Ultra-resolution’ are described 
in Box 2). The user may additionally generate DNA-PAINT data by in silico 
simulations. During image reconstruction, single-molecule fluorescence 
spots are localized, and resulting super-resolution images are visualized with 
‘Picasso: Render’. Image post-processing focuses first on drift-correction 
procedures. Then, special emphasis is given to analyzing the localization-
based DNA-PAINT data through picking regions of interest, performing 
kinetic and qPAINT analysis, averaging images for ultra-resolution analysis 
and channel alignment for Exchange-PAINT or filtering of the localization 
list. Program icons indicate in which Picasso component the respective step 
is performed—hexagons: ‘Design’; microchip: ‘Simulate’; mountain peaks: 
‘Localize’; paint palette: ‘Render’; funnel: ‘Filter’; stacked layers: ‘Average’. 
The Picasso program icons are based on contributions from the Noun Project 
(https://thenounproject.com)—‘Design’: hexagon by Creative Stall;  
‘Simulate’: microchip by Futishia; ‘Localize’: mountains by Montana Rucobo; 
‘Filter’: funnel by José Campos; ‘Render’: paint palette by Vectors Market; 
‘Average’: layers by Creative Stall.

http://www.jungmannlab.org
http://www.jungmannlab.org
http://www.jungmannlab.org
https://github.com/jungmannlab/picasso
https://thenounproject.com
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molecule (called the ‘scaffold’, derived from M13mp18 single-
stranded phage DNA) is folded into a desired shape by ~200 short,  
single-stranded DNA strands (called ‘staples’). Each staple has 
a defined sequence and specifically binds certain parts of the 
scaffold together. Structures are usually assembled in a one-pot 
reaction using thermal annealing. After the self-assembly is com-
pleted, the scaffold is ‘folded’ into the desired shape with the staple 
strands at prescribed positions in the final origami.

The rather complex and time-consuming procedure of manu-
ally designing DNA origami structures has been markedly simpli-
fied by computer-aided design tools, such as the freely available 
caDNAno36 and vHelix37 packages, as well as by simulation  
programs such as CanDo38. Furthermore, folding protocols for 
structure formation are now optimized for structure yield and 
folding speed39–41. In addition, several methods for subsequent 
purification of DNA nanostructures from unwanted excess of sta-
ple strands are described in the literature, such as agarose gel puri-
fication42, rate-zonal centrifugation43 or PEG purification44.

One of the early applications of DNA origami was its use as a 
microscopy standard in the form of a self-assembled nanoruler45. 
Owing to the unique positioning accuracy of DNA origami and 
its excellent structural integrity, the structures present an ideal 
platform to directly validate imaging methods and compare 
instrumentation. Specifically, they are a valuable tool in calibrat-
ing fluorescence and super-resolution microscopes46.

Although it is possible to create a wide range of structures with 
the DNA origami technique, some are more suitable for use as a 
reference structure with DNA-PAINT than others. In this proto-
col, we use a flat, rectangular 2D DNA origami structure, adapted 
from the one originally described33, here referred to as RRO. With 
dimensions of 90 × 70 nm and, in our case, 176 freely address-
able staples arranged in a hexagonal lattice with 5-nm spacing, 

it is an ideal structure for DNA-PAINT imaging (see Fig. 1b  
as an example). For surface immobilization, the structure is 
modified with eight biotinylated staple strands that can bind to 
a BSA–biotin–streptavidin-coated glass surface.

‘Picasso: Design’ is an essential tool in this protocol that reduces 
all design steps to a minimum. Figure 6 shows screenshots and 
outlines the procedure for creating DNA origami, from design to 
purification. For a detailed overview of the graphical user inter-
face, refer to Supplementary Figure 1. The program displays a 
hexagonal lattice that serves as a canvas representing all possible 
staple positions available for modification in the RRO struc-
ture. It features a ‘point-and-click’ approach, so that the desired  
pattern can be made by simply ‘painting’ on the canvas. Clicking 
a hexagon will fill it with a previously selected color; each color 
corresponds to a built-in staple extension on the 3′-end. As all 
modifications are just staple extensions of the RRO structure, 
the core sequences are not altered, and time-consuming tasks 
such as altering the routing of staples or modifying their base 
sequence are not necessary. In addition, ‘Picasso: Design’ auto-
matically calculates folding recipes for a given design based on 
optimized excess rates for the RRO and creates visual pipetting 
aids for 96-well plates so that pipetting of staple mixes is greatly 
facilitated. In consequence, the creation of DNA origami refer-
ence structures for DNA-PAINT can be achieved in the most  
straightforward way.

In situ sample preparation
A unique advantage of fluorescence microscopy, making it one 
of the preferred characterization tools in biological research, is 
its ability to interrogate biomolecules of interest, such as proteins 
or nucleic acids, with high efficiency and specificity. Generally,  
fluorescent labeling of target molecules is achieved either by 

Box 1 | Construction of a fluid exchange chamber for in situ imaging  
● TIMING 30 min 
Procedure
For in situ Exchange-PAINT experiments, we recommend a simple, custom-built fluid exchange system. The lid of an 8-well chambered 
cover glass can be modified with one inlet and one outlet, which can be connected to imaging and washing buffer reservoirs by 
silicone tubing. The modified lid can be used for multiple imaging experiments, although the connected tubing should be thoroughly 
cleaned before reuse. Using a syringe, flush at least 3 ml (as reference for 1-m tubing with a 1.5-mm diameter; adjust accordingly) of 
H2O, followed by 3 ml of 80% EtOH and finally 3 ml of H2O, through the tubing. Follow these instructions to prepare such a lid:
1. Drill two holes with a diameter of 1.5 mm into the lid of an 8-well chambered cover glass, so that two needles can penetrate it.
2. Use a rotary tool with cutting disc or equivalent to remove the syringe connectors from two 1.2 × 40-mm needles. Alternatively, use 
a side cutter (although this could potentially lead to a ‘less clean cut’) and squeeze the channel shut. To reopen, carefully apply pres-
sure with the side cutter at the side of the cut. Make sure that the needle is at least 2.5 cm long to be able to reach the bottom  
of the chambered cover glass.
! CAUTION Handle the needles with care and do not puncture yourself.
3. Cut away the sharp end of one of the needles, so the channel can reach the bottom of the wells. Carefully apply pressure to open 
the metallic channel of the needle at the cut side with the side cutter.
! CAUTION Handle the needles with care and do not puncture yourself.
4. Connect the cut needles to ~50 cm of tubing. Make sure that the tubing is long enough that there is enough space to handle the 
liquids and syringes at the microscope. To connect the tubing to the syringes, use 1.1 × 40-mm needles on the other end of the tubing.
 CRITICAL STEP The length of the tubing depends heavily on the accessibility of the microscope; adjust the tubing length for proper 
handling.
5. For imaging, fix the tubing to the microscope body via tape.
 CRITICAL STEP Leakage could lead to damage of the microscope. Check all tubing and connections before use.
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genetically fusing a protein tag to the target47 or by attaching an 
external binder molecule during a staining procedure—e.g., dye-
labeled antibodies48. For DNA-PAINT, the labeling requirement 
is that a DNA docking strand is attached to the target. Although 
a variety of strategies could be feasible for that29,30,49–52, this 
protocol focuses on immunostaining with DNA-conjugated anti-
bodies25. Specifically, we describe how antibodies can be chemi-
cally modified and used for in situ DNA-PAINT imaging of fixed  
cells (Steps 19–33).

The concept of in situ DNA-PAINT with primary and sec-
ondary antibody labeling is shown in Figure 1c: imager strands 
from solution transiently bind to handle sites on the secondary 
antibody. Imaging results for in situ samples prepared with anti-
body labeling are shown in Figure 1d,e, displaying a gradient 
overlay of diffraction-limited microtubules in comparison with 
the reconstructed super-resolved image. Furthermore, Figure 2g 
shows DNA DBCO-labeled antibody staining of Tom20, located 
mainly at the outer mitochondrial membrane, and DNA thiol-
labeled antibody staining of microtubules.

Various avenues are possible for attaching DNA strands to 
antibodies, including biotin–streptavidin linkage20 or covalent 
attachment of the DNA to the antibody22,53,54. Although biotin–
streptavidin linkage was used in the initial in situ DNA-PAINT 
demonstration20, we here discuss a covalent attachment strat-
egy, which was used in subsequent work22 similar to previously 
reported strategies for DNA–protein conjugation53,54. Here, an 
NHS ester linker is covalently attached to amino groups on the 
antibody and to certain functional groups on the DNA, such as 
reduced thiols22, azides53,55, alkynes53 or DBCO55, for click chem-
istry. This results in cross-talk-free attachment, as well as smaller 
linker sizes between antibody and DNA strand, as compared with 
the biotin–streptavidin linkage20.

Depending on the target molecules under investigation, it is 
furthermore important to evaluate different fixation strategies. 

For example, structural proteins, such as actin filaments or micro-
tubules, can be fixed with pre-extraction and glutaraldehyde to 
decrease background and preserve structural integrity56. However, 
structural artifacts can arise from the various fixation strategies. 
For an in-depth discussion of fixation artifacts, we refer to a recent 
article by Whelan et al.57. DNA-PAINT was also applied to tissue 
samples, as was recently shown in Drosophila embryos22, generally 
following the same procedures as described here. However, we do 
note that potential changes to the herein described protocol for 
more complex tissue samples might become necessary.

Data acquisition
A multitude of acquisition software packages are available for 
performing localization-based super-resolution microscopy, in 
particular for commercial microscope setups. In this protocol, we 
describe our procedures based on the freely available open-source 
acquisition software µManager58. µManager is used in a wide 
range of microscopy areas and offers broad device support for 
microscope bodies, cameras and peripherals. The Picasso software 
suite is specifically designed to be compatible with µManager.

Currently, two types of cameras are typically used in the field 
of single-molecule localization-based imaging—scientific com-
plementary metal oxide semiconductor (sCMOS)- and electron-
multiplying charge coupled device (EMCCD)-based cameras. 
sCMOS cameras provide better temporal resolution because of 
their faster readout electronics, resulting in a larger optical field 
of view as compared with EMCCDs under similar conditions. 
EMCCD cameras, in comparison, provide better quantum yields 
in low-light applications and thus higher signal-to-noise ratios59. 
As DNA-PAINT provides comparably higher signal-to-noise 
ratios (SNRs), both camera types are suitable in this context.

It has been shown that a pixel-dependent noise calibra-
tion for sCMOS cameras can improve localization precision in 
STORM60. However, for DNA-PAINT experiments—including the  

Box 2 | Ultra-resolution imaging ● TIMING ~7 h 
Procedure
To achieve ultra-resolution (<5 nm), imaging conditions must be carefully adjusted. The key to higher spatial resolution is to extract 
more photons per frame from a blinking event while simultaneously keeping the background low. This can be achieved by optimizing 
the laser excitation power, as well as the fluorescence ON time (and adjusting the integration time accordingly). The background can 
be reduced, for example, by decreasing the imager concentration. In this case, the acquisition time should be increased to ensure  
proper sampling of the target structure. However, with an imager concentration that is too low, drift correction might become less  
accurate owing to the smaller number of localizations per frame. We also want to note that the number of drift markers in a field of 
view should be as high as possible, to ensure precise drift correction. One way to achieve this is to make use of the larger field of  
view obtainable with today’s sCMOS cameras. For advanced drift correction, a 20-nm and a 10-nm grid DNA origami should be used  
as fiducials. Furthermore, oxygen-scavenging systems, such as the PCA/PCD/Trolox (PPT) system, allow the harvesting of more photons  
as they increase fluorophore stability27. The following steps describe in detail how to achieve ultra-resolution for imaging DNA  
origami structures.
1.  Design and fold DNA origami structures for ultra-resolution imaging—e.g., the LMU or MPI logo. In addition, fold 20-nm and  
10-nm grid DNA origami for use as drift markers (see Steps 1–17).
2. Prepare the oxygen-scavenging system PPT at least 1 h before imaging.
3. Prepare a sample with the target structure and DNA origami drift markers (see Step 18) using the following parameters:
● Origami solution ratio: 1/4 target structure (i.e. LMU or MPI logo), 1/4 20-nm drift marker, 1/4 10-nm drift marker  
and 1/4 Buffer B+
● Imager concentration (with PPT): 0.5 nM–1 nM.
4. Follow steps 34–48 with the following adjustments: 350 ms exposure time, 80,000 total number of frames. Set the excitation power 
density to ~4.5 kW/cm2 at the sample plane.
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ultra-resolution measurements in this protocol—we did not 
account for the pixel-dependent noise of our sCMOS camera. 
Although such calibration might also improve DNA-PAINT 
image quality, it was not required to achieve the ~1-nm localiza-
tion precision that allowed us to resolve 5-nm spaced binding sites 
on DNA origami structures (Fig. 4).

In this protocol, we generally suggest rather long camera inte-
gration times (a few hundred milliseconds) as compared with 
other localization-based microscopy methods such as PALM or 
STORM. Typically, for localization-based super-resolution tech-
niques, the integration time is roughly matched to the ON-time  
of blink events to maximize the signal-to-noise ratio of the fluo-
rescence image. Analogously, the integration times suggested here 
are roughly matched to the binding kinetics of the recommended 
nine-base-pair DNA duplex. This allows the collection of far more 

photons in a single frame as compared with typical PALM or 
STORM experiments, thus enabling better localization precision. 
However, it is worth noting that the combination of slower blink-
ing and longer integration time comes at the expense of extended 
total data acquisition time to detect the same number of events. 
Nonetheless, it is certainly possible to shorten the binding duration,  
integration time and thus the total acquisition time by using DNA 
duplexes with fewer base pairs. For example, the recommended 
integration time for 8-mers is only tens of milliseconds and that 
for 7-mers is even less. With such faster kinetics, the integra-
tion time and achievable localization precision would then be 
similar to those in PALM or STORM experiments. An advantage 
of DNA-PAINT is therefore that it gives the researcher intricate 
control over the desired localization precision as a trade-off for 
total acquisition time.

Box 3 |  In silico simulation of DNA-PAINT data ● TIMING 10–60 min 
Picasso’s simulation module (‘Picasso: Simulate’) is a tool for evaluating experimental conditions for DNA-PAINT and generating ground-
truth data for test purposes. This allows systematic analysis of how different experimental parameters such as imager concentration, 
target density or integration time influence the imaging quality and whether the target structure can be resolved with DNA-PAINT.
By default, ‘Picasso: Simulate’ starts with preset parameters that are typical for a DNA-PAINT experiment. Thus, meaningful raw  
DNA-PAINT data can be readily simulated for a given input structure without the need of a super-resolution microscope. The simulation 
output is a movie file in .raw format, as it would be generated during an in vitro DNA-PAINT experiment on a microscope.

Procedure
1. Start ‘Picasso: Simulate’.
2. Define the number and type of structures that should be simulated in the group ‘Structure’. Predefined grid- and circle-like structures 
can be readily defined by their number of columns and rows, or their diameter and the number of handles, respectively. Alternatively, 
a custom structure can be defined in an arbitrary coordinate system. To do so, enter comma-separated coordinates into ‘Structure X’ 
and ‘Structure Y’. The unit of length of the respective axes can be changed by setting the spacing in ‘Spacing X,Y’. For each coordinate 
point, an identifier for the docking site sequence needs to be set in ‘Exchange labels’ as a comma-separated list. Correctly defined 
points will be updated live in the ‘Structure [nm]’ window. Note that entries with missing x coordinate, y coordinate or exchange label 
will be disregarded. When a structure has been previously designed with ‘Picasso: Design’, it can be imported with ‘Import structure 
from design’. A probability for the presence of a handle can be set with ‘Incorporation’. By default, all structures are arranged on a  
grid with boundaries defined by ‘Image size’ in ‘Camera parameters’ and the ‘Frame’ parameter in the ‘Structure’ group. ‘Random  
arrangement’ distributes the structures randomly within that area, whereas ‘Random orientation’ rotates the structures randomly.  
Selecting the button ‘Generate positions’ will generate a list of positions with the current settings and update the preview panels.  
A preview of the arrangement of all structures is shown in ‘Positions [Px]’, whereas an individual structure is shown in ‘Structure [nm]’.
3. The group ‘PAINT Parameters’ allows adjustment of the duty cycle of the DNA-PAINT imaging system. The mean dark time is  
calculated by τd = (kon·c)−1. The mean ON time in a DNA-PAINT system is dependent on the DNA duplex properties. For typical 9-bp 
imager/docking interactions, the ON time is ~500 ms. ON times can be experimentally estimated with Picasso as described in Step 69B.
4. In ‘Imager Parameters’, fluorophore characteristics such as PSF width and photon budget can be set. Adjusting the ‘Power density’ 
field affects the simulation analogously to changing the laser power in an experiment.
5. The ‘Camera parameters’ group allows the user to set the number of acquisition frames and integration time. The default image size 
is set to 32 pixels. As the computation time increases considerably with image size, it is recommended to simulate only a subset of the 
actual camera field of view.
6. Select ‘Simulate data’ to start the simulation. The simulation will begin by calculating the photons for each handle site of every 
structure and then converting it to a movie that will be saved as a .raw file, ready for subsequent localization. All simulation settings 
are saved and can be loaded at a later time with ‘Load from previous simulation’.
?  TROUBLESHOOTING
7. (Optional step for multiplexing) Multiplexed Exchange-PAINT data can be simulated by adjusting the ‘Exchange Labels’ setting.  
For each handle in the custom coordinate system (‘Structure X’, ‘Structure Y’), an Exchange round can be specified. The different  
imaging rounds can be visually identified by color in the ‘Structure [nm]’ figure. For each round, a new movie file will be generated.  
By default, the simulation software detects the number of exchange rounds based on the structure definition and will simulate all  
multiplexing rounds with the same imaging parameters. It is possible to have different imaging parameters for each round, e.g.,  
when using image s with different ON-times. To do so, one can simulate multiplexing rounds individually. In the ‘Exchange rounds  
to be simulated’ field, enter only the rounds that should be simulated with the current set of parameters. Change the set parameters 
and the multiplexing round and simulate the next data sets. Repeat until all multiplexing rounds are simulated.



©
20

17
 M

ac
m

ill
an

 P
u

b
lis

h
er

s 
L

im
it

ed
, p

ar
t 

o
f 

S
p

ri
n

g
er

 N
at

u
re

. A
ll 

ri
g

h
ts

 r
es

er
ve

d
.

© 2017 Macmillan Publishers Limited, part of Springer Nature. All rights reserved.

protocol

nature protocols | VOL.12 NO.6 | 2017 | 1207

The number of localizations and thus the total experiment time 
strongly influence the resolution of a localization-based super-
resolution image. Ideally, to resolve a target structure, it should 
be spatially probed at least at its Nyquist frequency61. More pre-
cisely, it has been shown that the overall image resolution for 
localization-based super-resolution microscopy is governed by 
two main factors: sampling density and localization precision16. 
In the same work, it was demonstrated that longer acquisition 
times increase spatial resolution of the reconstructed image 
because of increased spatial sampling up to the point at which 
image resolution is solely limited by localization precision. As the 
molecule density of a target structure might be unknown, it is 
often necessary to evaluate a range of acquisition times to deter-
mine how many frames are sufficient to represent the structure 
with the desired resolution. In silico simulations of localization- 
based super-resolution imaging can be a practical method of 
assaying a large number of data acquisition parameters such as 
the total acquisition time62, reducing the need for time-con-
suming experiments. The Picasso software package comes with 
a module for simulating DNA-PAINT data, thus providing the 
tools for this approach. A more detailed discussion of the ‘Picasso: 
Simulate’ module follows below. Finally, we want to provide an 
exemplary thought-experiment as a guide to estimating appro-
priate acquisition lengths t. Consider an imager concentration 

c of 10 nM and a probe association rate kon of 106 (Ms)−1. This 
leads to a mean time in between binding events (or dark time 
τd) for a single site of 100 s according to τd = (kon × c)−1. For an 
~98% probability (P) of any single binding site being visited at 
least once, a total imaging time of t = 4 × τd = 400 s is required, 
according to P = 1 – e−t/τd. To achieve multiple binding events 
per site resulting in a decent image quality, we recommend a total 
imaging time of ~33 min.

In silico simulation of DNA-PAINT data
A fundamental challenge in single-molecule localization micro-
scopy is to systematically design, optimize and validate super-
resolution experiments. In silico simulations provide a convenient 
way to address this challenge. Software packages such as SuReSim 
generate a ground truth model and simulate localization micros-
copy data using parameters matching an experimental microscope  
setup62. Similar to this approach, the Picasso software suite 
can simulate localization data with its ‘Simulate’ component, 
which is specifically tailored to DNA-PAINT. In a graphical 
user interface, shown in Figure 7 and Supplementary Figure 2, 
simulation parameters can be set for the type of target struc-
ture, DNA-PAINT kinetics, dye properties and hypothetical data 
acquisition settings such as integration time and total number of  
acquisition frames.

PAINT
staples

Core
staples

Thermal
annealing

Print pipetting scheme

(i) Design

(iv) Folding table

(ii
) 

O
rd

er
 p

la
te

 li
st

Folded DNA origami

(v)
Scaffold
biotin staples
water
buffer

++

(vi) Agarose gel

(iii)
 Use as visual pipettin

g aid

Ex

L S

P
oo

l a
ll 

st
ap

le
s

of
 s

am
e 

co
lo

r
Figure 6 | Designing DNA origami structures for DNA-PAINT with ‘Picasso: Design’. (i) Screenshot of the design interface displaying a 20-nm grid structure  
with 12 docking sites (red) selected to carry the extension P1. After design is completed, a list of plates is generated as a .csv file ready for ordering (ii). 
‘Picasso: Design’ also creates PDF sheets that can be placed underneath the ordered 96-well plates to facilitate pipetting of staple strands (iii). The folding 
table (iv) gives detailed instructions for preparing components to assemble the DNA nanostructure through thermal annealing. Staple master mixes are 
pipetted from the plates according to the pipetting scheme. For a successful assembly process, single-stranded DNA scaffold, biotinylated staples, staple 
master mixes (unmodified core (gray) and docking-strand-extended (red) staples), water and folding buffer need to be mixed (v). After structures are formed 
(usually through thermal annealing), an agarose gel can be run for analysis or subsequent structure purification (vi). Here, a DNA ladder (L) and the  
scaffold strand (S) are seen as clear bands together with bands for the correctly folded DNA structures and excess staple strands (Ex). Extracted origami 
structures are now ready for DNA-PAINT imaging.
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The simulated imaging targets are nanometer-sized 2D struc-
tures (similar to RROs) on which the positions of DNA-PAINT 
handles can be defined. These handles serve as a ground truth 
model for localization events. On the basis of the values set for 
DNA-PAINT kinetics, the simulation algorithm will calculate a 
kinetic series of ON- and OFF-events over the total acquisition 
time for each handle.

The duration of an ON-event is calculated by random selection 
from an exponential distribution defined by a mean ON-time. 
This time can be either determined experimentally (i.e., using 
Picasso’s kinetic analysis tool; see Step 69B) or estimated by the 
number of base pairs in the imager/docking strand duplex19.  
The length of an OFF-event is generated accordingly. Here, the 
mean OFF-time is calculated from the user-defined binding rate 
constant and the imager concentration19.

The user-defined integration time of the simulated camera is 
used as a sampling window to calculate how long an imager was 

bound during each frame. To emulate experimental results, the 
simulation randomly selects a photon detection rate for each 
binding event from a normal distribution. The mean and standard 
deviation of this normal distribution increase linearly with the 
user-definable laser power density according to experimentally 
determined coefficients. For each frame (or fraction of a frame) in 
which the binding event occurs, the detected number of photons 
is then selected randomly from a Poisson distribution. The mean 
of this Poisson distribution is equal to the mean expected photon 
number for the binding event duration within this frame (photon 
detection rate × duration). In addition, the simulation considers 
an upper-limit for detected photons from a single binding event, 
based on a user-defined photon budget per fluorophore.

After the number of photons for all binding events in each 
frame is calculated, photons are distributed around the center 
position of their handle by a user-adjustable 2D normal distribu-
tion, representing the microscope’s point spread function (PSF). 
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Figure 7 | Simulating DNA-PAINT raw data from DNA origami-like structures. (a) Overview of the graphical user interface for ‘Picasso: Simulate’. A DNA-PAINT 
simulation can be defined by parameters in four categories, indicated by colored frames: ‘Structure’ (blue), PAINT parameters (red), ‘Imager parameters’ 
(green) and ‘Camera parameters’ (yellow). Two overview plots are shown in the upper row. ‘Positions [Px]’ shows the arrangement of individual structures 
within the field of view and ‘Structure [nm]’ shows the positions of DNA-PAINT binding sites in an individual structure. The positions of binding sites in 
individual structures can be defined in the ‘Structure’ section by (i) importing RRO structures designed with ‘Picasso: Design’, (ii) using predefined geometric 
shapes (circles, grids), or (iii) manually entering coordinates. In the ‘PAINT parameters’ section, kinetic parameters for DNA-duplex formation can be set. 
Imager-related properties (PSF width, laser power, photon budget, photon detection rate and background) are defined in the ‘Imager parameters’ section. 
Last, acquisition settings, such as image size, integration time, number of frames and pixel size can be set in the ‘Camera parameters’ section. (b) Example 
of simulated raw DNA-PAINT data in ‘Picasso: Localize’ after spot identification and fitting. The simulation program simulates blinking events as if they were 
acquired with a microscope. (c) Reconstructed DNA-PAINT image from data generated with ‘Picasso: Simulate’. The overview of all structures corresponds 
to the ‘Positions [Px]’ window shown in a. A close-up shows the structure that is presented in the ‘Structure [nm]’ window in a. (d) Example of an iterative 
process for optimizing DNA-PAINT experiments with simulations. A DNA origami structure is simulated with an imager concentration of 1 nM (Simulation 1). 
The simulation shows that the concentration is too low, because features of the structure are not clearly visible. Consequently, in a next iteration, data are 
simulated with a higher concentration, here 20 nM (Simulation 2). Now the simulation reveals that the imager concentration chosen is too high, resulting 
in ‘cross-talk’ localizations between the structures. Such cross-talk arises when two imagers bind simultaneously to nearby structure sites. Their diffraction-
limited images spatially overlap and are falsely identified as a single event with a fitted center coordinate in between the two true positions. For the next 
iteration, the imager concentration is decreased to 5 nM. The resulting simulation shows structures with clear features and no inter-structure cross-talk. 
Hence, the 5 nM imager concentration was chosen to perform a DNA-PAINT experiment (Experiment), which in turn is in good agreement with the simulation. 
Scale bars, 500 nm (c), 100 nm (c inset, d).
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This results in a list of all photon positions for each frame, which 
is converted to an image by calculating a 2D histogram. Poissonian 
noise is added to each frame specified by the background level. 
Finally, the frames are exported as a raw movie file. The default 
values for all parameters were estimated from calibration  
experiments on our TIR fluorescence (TIRF) setup described in 
the EQUIPMENT section. The imager sequence for calibration 
experiments was CTAGATGTAT (P1), which was labeled with a 
Cy3B dye that was excited by a 561-nm laser.

Super-resolution image reconstruction
After a movie of DNA-PAINT data has been acquired (either  
in silico, in vitro or in situ), single-molecule spots must be identi-
fied and fitted to find their center position with subpixel accuracy. 
These routines are performed with Picasso’s ‘Localize’ compo-
nent. An overview of the graphical user interface with identified 
and fitted localizations is shown in Supplementary Figure 3,  
as well as screenshots of parameter dialogs.

A multitude of spot identification algorithms have been devel-
oped and applied to localization-based super-resolution micro-
scopy63. In ‘Picasso: Localize’, spot identification makes use of 
the image gradient to minimize the impact of nonhomogeneous 
background. First, local maxima are detected by identifying pixels 
with highest count in their local neighborhood. This local neigh-
borhood is defined by a square box around the pixel with a user-
defined side length. Then, the net gradient (Gnet) is calculated for 
each box around a local maximum pixel by 

Gnet i i
box

= ⋅∑ g u

where the sum is taken over all pixels of the box, gi is the central 
difference gradient at pixel i and ui is a unit vector originating 
at pixel i and pointing toward the center pixel of the box. Hence, 
the net gradient of a spot is the sum of intensity flowing toward 
the spot center, which is roughly proportional to the number of 
signal photons. A user-defined minimum threshold for the net 
gradient defines whether a spot will be further considered for 
fitting or disregarded.

After spots have been identified by the net gradient method, 
their box serves as input for a maximum likelihood fitting pro-
cedure64. Although a plethora of spot-fitting algorithms have 
been published and used for localization microscopy63, we chose 
to implement the maximum likelihood algorithm because it 
achieves theoretically minimum uncertainty at the Cramer-Rao 
lower bound with good computational performance. However, 
it is critical to this fitting algorithm that the camera images be 
converted correctly to photons, because the algorithm incorpo-
rates the Poisson noise statistics inherent to light detection. In 
‘Picasso: Localize’, the user can set the required parameters for 
converting camera counts to photons. One result of the maximum  
likelihood fitting is the Cramer-Rao lower bound (CRLB) for each 
spot. The localization precision is then obtained by calculating 
the square root of the CRLB.

Finally, super-resolution images are rendered with the ‘Picasso: 
Render’ component based on a list of subpixel spot center coordinates  
(see Supplementary Fig. 4 for an interface overview). The super-
resolution image is a pixel image with arbitrary pixel size, although 
super-resolution pixels that are too large result in insufficient spa-
tial sampling and a potential loss in resolution. We define the ratio 

of super-resolution image pixels to camera pixels as the ‘oversam-
pling’ parameter. In Picasso, the oversampling can be set either 
manually or automatically according to how far the user zooms 
into the image. In the dynamic case, each computer display pixel 
corresponds to one pixel of the super-resolution image.

Picasso offers several rendering modes for the super-resolution  
image. The basic option is to use no ‘Blur’, in which case the 
super-resolution image is merely a 2D histogram of localization 
coordinates65. The second option is ‘One-Pixel-Blur’, in which the 
2D histogram is convolved with a Gaussian probability density 
function of volume and standard deviation equal to one. The 
third option, ‘Global Localization Precision’, is similar to the 
‘One-Pixel-Blur’. However, the standard deviation of the Gaussian 
kernel is set to the median localization precision of all localiza-
tion coordinates. In the fourth option, ‘Individual Localization 
Precision’, each localization is added to the super-resolution image 
as a Gaussian probability density with volume equal to one and 
standard deviation equal to the individual coordinate localization  
precision3. For the localization-precision-based representation 
methods (‘Global’ and ‘Individual Localization Precision’), a 
minimum blur width can be defined by the user, so that the blur 
width is equal to the localization precision, unless the precision 
is smaller than the set minimum blur width.

Picasso furthermore allows for contrast adjustment of the 
super-resolution image based on the density of localizations in 
one super-resolution image—i.e., the number of localizations per 
pixel (or in the case of ‘blurred’ images, the sum of probability 
densities from localizations at each pixel).

Drift correction
A critical post-processing step for localization-based super-resolu-
tion imaging is to compensate for stage drift that occurred during 
data acquisition. In fact, with intricate drift correction methods, 
extremely high resolution (well below 5 nm) can be achieved23. 
After such post-processing steps, drift is almost completely 
removed as a factor for resolution degradation. Consequently, 
localization precision and structure sampling are the only remain-
ing factors that determine image quality. Even so, localization  
precision can be greatly optimized, because DNA-PAINT decou-
ples dye photophysics from blinking, and particle averaging 
(described below) allows reducing of the effects of undersampling 
the structure of interest.

Picasso offers two major routes for drift correction: (i) using 
the localization events themselves and (ii) using specific fidu-
cials in the sample. The localization-events-based drift correction 
is an implementation of a redundant cross-correlation (RCC) 
algorithm66 in which localizations are split and rendered into 
multiple super-resolution images according to their temporal 
appearance in the movie. Image cross-correlation of all result-
ing super-resolution images then yields the spatial shift between 
temporal movie segments from which the drift is interpolated. 
Another conventional way for compensating drift in localization-
based super-resolution microscopy is by using fiducial markers3. 
Such fiducial markers are luminescent and typically observed in 
the same emission channel as the fluorescent signal. Commonly 
used fiducials are gold nanoparticles, quantum dots and fluores-
cently dyed microspheres. With Picasso, localizations from such 
fiducial markers can be selected and used for drift correction, 
as the localizations can be assumed to originate from a single  
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point-like source. Recent developments in extremely high reso-
lution in DNA-PAINT applications have used a large number 
of DNA origami as fiducial markers23. When using hundreds of 
DNA origami structures as markers, their intrinsic size does not 
affect the drift estimation because of their random rotational 
orientation. In the same work, an additional drift correction 
step was applied by selecting single DNA-PAINT binding sites as 
drift markers. Similar to the case of whole DNA origami, a large 
number of binding sites (usually several thousands) are required, 
as each individual site does not comprise sufficient localizations 
to interpolate the drift for each movie frame accurately. Although 
DNA origami and their DNA-PAINT binding sites are excellent 
choices, this type of fiducial-based drift estimation is not limited 
to these structures. It is feasible to use any distinctly visible land-
marks in the image as fiducial markers—for example, protein 
clusters such as the nuclear pore complex.

In this protocol, we recommend subsequent applications of drift 
correction by RCC and, if available, fiducial-based correction with 
DNA origami markers followed by fiducial-based correction with 
single DNA-PAINT binding sites as markers. Example results after 
each drift correction step of such a process are shown in Figure 4b. 
In the final images, drift is almost completely eliminated as a factor 
in image resolution. This is corroborated by the fact that the spread 
of imaged DNA-PAINT binding sites is similar to the estimated 
localization precision by nearest neighbor analysis (NeNA)67.

Multiplexing
One major benefit of DNA-PAINT is its straightforward exten-
sion to multiplexed imaging. Here, the simplest implementation 
is to use spectrally distinct dyes coupled to orthogonal imager 
sequences68. Unlike other multiplexed localization-based super-
resolution techniques69, no photo-switching of dyes is necessary, 
and thus it is rather simple to find compatible spectrally distinct 
fluorophores68 (i.e., Atto488, Cy3B and Atto655).

However, one major drawback of spectral multiplexing is the 
limited number of distinguishable dyes in the visible spectrum. 
This limitation can be overcome with Exchange-PAINT20. Here, 
the unique programmability of DNA-PAINT docking and imager 
strands is used to enable spectrally unlimited multiplexing by 
sequentially applying orthogonal imager strands (carrying the 
same dye) to targets of interest.

In each imaging round, only one imager species is present in solu-
tion for one target. After acquisition, the imager is washed out and 
the imager for the next round is introduced. This is then repeated 
for the total number of targets. A multicolor image is achieved by 
assigning a pseudocolor to each imaging round and stacking the 
acquisitions on top of each other, which is depicted in Figure 2a.

Preparation of samples for Exchange-PAINT is similar to that 
for singleplex experiments, only that an open chamber allowing 
for fluid exchange is used as displayed in Figure 2b,c.

To create multicolor images, Picasso automatically assigns pseu-
docolors when several data sets are loaded. Different imaging rounds 
potentially comprise an offset with respect to each other because of 
instrumentation drift during data acquisition. However, alignment 
procedures can detect and correct for such image offsets.

Picasso offers cross-correlation or fiducial-based alignment 
algorithms. When images share features as reference points, such 
as DNA origami or the general cell shape, the cross-correlation 
can align images with high precision—e.g., sub-5-nm channel 

alignment, as demonstrated in Figure 2d–f. When few reference 
points are available, e.g., for in situ imaging of different cell tar-
gets, alignment markers or drift fiducials can be added to the 
sample and used in Picasso’s alignment procedure.

A distinct advantage of Exchange-PAINT over spectral multi-
plexing is that for each imaging round the same dye is used, and 
thus misalignment and inhomogeneous image warping due to 
chromatic aberrations are avoided. This allows for very precise 
channel alignment and makes Exchange-PAINT ideal for colocali-
zation studies to assess spatial proximity and possible molecular 
interactions. Such results are illustrated in the in situ example 
in Figure 2g, in which the morphology of the mitochondrial  
network and the spatial relationship to microtubules is studied. 
It shows how mitochondria are embedded in the microtubule 
network, as described in previous work70.

Quantitative imaging with qPAINT
Most super-resolution studies to date harness their exquisite sub-
diffraction spatial resolution to address challenges in the bio-
logical sciences by structural imaging. However, although still 
challenging, counting integer numbers of biomolecules when 
localization precision is insufficient to spatially resolve them can 
bring further insight into biological systems8,71,72. To achieve this, 
researchers began using the spatiotemporal information of single-
molecule localization microscopy data sets beyond just binning 
localization events for visualization. The basic concept involves 
extracting molecule numbers by evaluating the kinetics of the 
blinking behavior of photoswitchable molecules73–75. Most of 
these counting techniques use rather complex modeling of the 
dye photophysics, in some cases combined with spatiotemporal 
clustering72–76. However, incumbent techniques have certain limi-
tations that prevent them from achieving the highest accuracy and 
precision over a wide range of molecular densities in resolution-
limited areas. These limitations generally lead to overcounting 
or undercounting artifacts, because the dyes typically have envi-
ronmentally sensitive photophysics that are hard to predict and 
model. Furthermore, distinct dyes behave differently even under 
similar experimental conditions, which severely complicates 
multiplexed quantitative imaging. In addition, inhomogeneous 
excitation and photoactivation intensities due to uneven illumina-
tion across a sample can lead to inaccurate quantification as well.  
Last, dyes typically bleach over the course of an experiment, which 
deteriorates quantification accuracy and precision.

Recently, DNA-PAINT has been used to achieve precise and accu-
rate counting—because of its independence from dye photophysics 
and immunity to photobleaching—in an implementation called 
qPAINT22. In contrast to the traditional approach of fixing blinking 
dyes to the target molecule, DNA-PAINT creates target ‘blinking’ by 
transient binding of dye-labeled imager strands to complementary 
docking strands on the target. As opposed to dye photoswitch-
ing, DNA hybridization kinetics is more predictable. Hence, com-
bined with the effective absence of photobleaching, qPAINT can  
extract molecule numbers with high precision and accuracy.

Figure 3 illustrates the procedure and results of a typical 
qPAINT experiment. Using Picasso’s quantification capabilities, 
we now provide users with an integrated software solution for 
calibrating and quantifying molecule numbers in DNA-PAINT 
data sets. qPAINT relies on the fact that mean dark times for a 
given influx rate of imager strands (ξ = kon × c) are dependent 
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only on the number of docking strands (and thus biomolecules) 
in an area of interest. To illustrate this, we compare two DNA 
origami structures, carrying 12 or 42 binding sites in 20-nm and 
10-nm grid arrangements, respectively (Fig. 3a). A schematic  
representation of their respective intensity vs. time traces is shown 
in Figure 3b. By plotting the cumulative distribution function 
of both dark time distributions, we can obtain mean dark times 
for the two structures (Fig. 3c). To translate these dark times to 
actual numbers of binding sites (or units), the influx rate per 
unit needs to be calibrated. This can be achieved with DNA ori-
gami structures in which binding sites can be visually identified 
(see Fig. 3d, 20-nm grid structures displaying 12 binding sites).  
In Picasso, users can now select these calibration structures dis-
playing a known number of units (or binding sites in this case) 
and calibrate the probe influx rate for subsequent quantification 
of target molecules of interest in the same data set (Fig. 3d).

The results for a typical qPAINT experiment post calibration 
are illustrated in Figure 3e–g. 20-nm DNA origami grid structures 
can be used to compare visually counted numbers of spots with 
qPAINT results, which are in good agreement (Fig. 3e). Note that 
not all DNA origami carry all binding sites, because typical staple 
incorporation efficiencies are <100%. qPAINT allows binding-site 
identification on 10-nm DNA origami grid structures, in which 
single sites are not clearly identifiable (Fig. 3f).

Finally, Picasso allows users to quickly obtain statistics from 
qPAINT data sets using its integrated ‘Pick’ and ‘Pick similar’ 
tools. Figure 3g illustrates the resulting number of binding-site 
distributions for 20-nm and 10-nm DNA origami grid struc-
tures in a single sample. The average number of binding sites is 
in excellent agreement with expectations. For 20-nm structures, 
the incorporation efficiency is ~78%, whereas it is slightly lower 
for 10-nm grid structures at 70%. This, however, is to be expected, 
as staple incorporation efficiency should be lower for larger num-
bers of modified staple strands in DNA origami structures.

Filtering localizations
After identification and fitting of single-molecule spots, filtering 
the list of localizations might improve super-resolution image 
quality3,5,6,69,70,77. Only after fitting a single-molecule spot, are 
properties such as spot width or an accurate estimation of the 
number of photons available. Hence, spot identification itself 
may not reliably rule out false-spot detections. A typical filter-
ing procedure is to remove localizations with spot widths that 
are too small or too large. Ideally the spot width matches that of 
the microscope’s PSF. Therefore, if the spot width is, for exam-
ple, too big, it is likely that the spot originates from two close-
by and overlapping events. The resulting fit coordinate will be 
between the two correct center positions and should therefore 
be disregarded. Another example of filtering is to remove local-
izations with a number of photons or a localization precision 
that is too low. After such filtering, the super-resolution image 
quality can improve, because only high-precision localizations 
remain. Picasso’s ‘Filter’ component provides a convenient, visu-
ally guided way to filter localizations based on histograms of their 
properties. An overview of its graphical user interface, as well 
as screenshots of filtering procedures in progress, is shown in 
Supplementary Figure 5. We recommend studying histograms 
of localization properties and joint histogram maps of two 
localization properties with the goal of identifying the true signal  

population and removing false populations or outliers. An 
overview of localization properties saved by Picasso is shown  
in the Supplementary Manual.

Particle averaging
When imaging a structure that appears multiple times in the 
field of view, aligning the individual images on top of each other 
and ‘summing them up’ can generate an ‘average’ image with 
improved image quality23,78. Such a procedure is analogous to the 
particle averaging often applied for structural biology in single-
particle electron microscopy79 and has already been successfully 
applied to localization-based super-resolution microscopy80,81. 
Although, strictly speaking, we do not create an ‘averaged’ but 
rather a ‘sum image’ from all localizations, we here will con-
tinue to use the notion of averaging as a historical term from 
the electron microscopy field. ‘Averaging’ primarily increases 
the image signal-to-noise ratio, which translates for localization 
microscopy to the proportion of true, high-precision localiza-
tions (signal) to false or imprecise localizations (noise). Hence, 
structure sampling, a major factor for image resolution16, can be 
improved by the averaging procedure. This is exemplified by the 
individual and average images of two RRO DNA origami struc-
tures in Figure 4c–f, showing the letters ‘MPI’ and ‘LMU’. The 
average image comprises a greatly enhanced signal-to-noise ratio 
as compared with images of individual structures. Moreover, 
even though some binding sites are missing in individual struc-
tures, averaging could reconstruct all binding sites and resolve 
their ~5-nm distances well.

Picasso offers a graphical user interface for averaging multiple 
images of the same structure with the ‘Average’ component. The 
underlying algorithm does not require a reference and is based 
on a traditional procedure borrowed from single-particle electron 
microscopy82. Briefly, the individual images are first translation-
ally aligned on top of each other by overlaying the center of mass 
of localizations. Then, several iterations of rotational and refined 
translational alignment are applied. In each iteration, an average 
image is constructed by pooling all localizations and rendering 
them on a super-resolution pixel grid. Then, localizations from 
each individual structure are rotated over 360 degrees in small 
steps and rendered as a super-resolution image for each rotational 
step. The angular step size is dynamically chosen so that the rota-
tion distance at twice the root mean square (RMS) deviation of all 
localizations from their center of mass matches the size of a super-
resolution pixel. Each rotated image is cross-correlated with the 
average image of the current iteration, and the maximum value and 
position of the cross-correlation are recorded. Finally, the localiza-
tions of an individual structure are rotated and translated according 
to the rotation and translation with the highest cross-correlation 
value. In the next iteration, a new improved average image can be 
generated from the now updated localization coordinates. After a 
certain number of iterations, the average image will converge—i.e., 
the pixel values will not change after an iteration. At this point, the 
algorithm can be stopped, and the new localization list is saved.

Averaging results, as shown in Figure 4e,f, rely on experimental 
conditions and post-processing steps that are specifically aimed 
at ultra-resolution. In particular, intricate drift correction as 
described above is a key contribution. Experimental conditions for 
ultra-resolution are described in Box 2; refer to Supplementary 
Figures 6–9 for structure design.
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MATERIALS
REAGENTS
! CAUTION All reagents can be potentially hazardous and should be handled 
only by trained personnel.
DNA labeling

PBS, pH 7.2 (Life Technologies, cat. no. 20012-019)
0.5 M EDTA, pH 8.0 (Ambion, cat. no. AM9261) ! CAUTION EDTA may 
cause eye and skin irritation; avoid breathing the dust or fumes.
DMF (Thermo Fisher Scientific, cat. no. 20673) ! CAUTION DMF is a toxic 
and flammable liquid; protect your eyes and skin, and avoid breathing the 
dust or fumes. It may also damage fertility and cause harm to the unborn 
child. Handle it under a chemical hood.
AffiniPure Donkey Anti-Rat IgG (Jackson ImmunoResearch,  
cat. no. 712-005-150)
AffiniPure Donkey Anti-Rabbit IgG (Jackson ImmunoResearch,  
cat. no. 711-005-152)
AffiniPure Goat Anti-Mouse IgG (Jackson ImmunoResearch,  
cat. no. 115-005-003)

Antibody labeling via maleimide-PEG2-succinimidyl ester
Maleimide-PEG2-succinimidyl ester (Sigma-Aldrich, cat. no. 746223)
No-Weigh Format DTT (Thermo Fisher Scientific, cat. no. 20291)  
! CAUTION This compound causes skin and respiratory pathway irritation, 
as well as serious eye irritation. It is toxic if swallowed and causes long-term 
damage to aquatic life.
Micro BCA Protein Assay Kit (Thermo Fisher Scientific, cat. no. 23235)
Thiol-DNA (P1 handle: Thiol-TTATACATCTA; MWG Eurofins)
Thiol-DNA (P3 handle: Thiol-TTTCTTCATTA; MWG Eurofins)

Antibody labeling via DBCO-sulfo-NHS ester
DBCO-sulfo-NHS ester (Jena Bioscience, cat. no. CLK-A124-10)
Azide-DNA (Biomers.net) P1 Handle: Azide-TTATACATCTA
Azide-DNA (Biomers.net) P3 Handle: Azide-TTTCTTCATTA

Immunofixation and cell imaging
8-well chambered cover glasses (Eppendorf, cat. no. 0030742036 or  
Thermo Fisher Scientific, cat. no. 155409)
BSA (Sigma-Aldrich, cat. no. A4503-10g)
Triton X-100 (Carl Roth, cat. no. 6683.1) ! CAUTION This compound is 
toxic if swallowed, and it can cause serious eye damage.
0.22-µm sterile filters (Merck/EMD Millipore, cat. no. SLGS033SS)
Sodium chloride (Ambion, cat. no. AM9759) ! CAUTION Sodium  
chloride may cause skin and eye irritation, and it may be harmful if  
inhaled or swallowed.
Sodium borohydride (Carl Roth, cat. no. 4051.1) ! CAUTION This  
compound reacts in a volatile manner with H2O, is toxic if swallowed  
and can cause serious skin damage. Handle it under a chemical hood.
16% (vol/vol) Paraformaldehyde (Electron Microscopy Sciences,  
cat. no. 15710) ! CAUTION This compound is flammable, a carcinogen and 
toxic if swallowed; avoid breathing the fumes or dust. It can cause serious 
eye, skin or respiratory pathway irritation. Handle it under a chemical hood.
25% (vol/vol) Glutaraldehyde (SERVA, cat. no. 23115.01) ! CAUTION Glu-
taraldehyde is toxic if swallowed; it causes serious skin damage, and acute 
and chronic toxicity in aquatic life. Avoid breathing the fumes or dust. Wear 
protective equipment and handle the compound under a chemical hood.
α-Tubulin (YL1/2) antibody (Thermo Fisher Scientific, cat. no. MA1-80017)
α-Tubulin (DM1A) mouse antibody (Cell Signaling, cat. no. 3873S)
Tom20 (FL-145) rabbit antibody (Santa Cruz, cat. no. sc-11415)
DNA-labeled secondary antibodies and imager kit (Ultivue, cat. no. U10001)
Imager strand (P1-Cy3B: CTAGATGTAT-Cy3B; Eurofins Genomics)
Imager strand (P3-Atto655: GTAATGAAGA-Atto655; Eurofins Genomics)
Imager strand (P3-Cy3B: GTAATGAAGA-Cy3B; Eurofins Genomics)

Cell culture
PBS, pH 7.2 (Thermo Fisher Scientific, cat. no. 20012-019)
MEM (Thermo Fisher Scientific, cat. no. 31095-052)
Eagle’s Minimum Essential Medium (EMEM; ATCC, cat. no. 30-2003)
l-Glutamine (Thermo Fisher Scientific, cat. no. 25030-149)
Non-essential amino acids (Thermo Fisher Scientific, cat. no. 11140-035)
FBS (Thermo Fisher Scientific, cat. no. 10500-064)
Penicillin–streptomycin (P/S; Thermo Fisher Scientific, cat. no. 15140-122) 
! CAUTION It may damage fertility and cause harm to the unborn child. 
Avoid breathing fumes or dust.
Trypsin-EDTA (Thermo Fisher Scientific, cat. no. 25300-054)

•
•

•

•

•

•

•
•

•
•
•

•
•
•

•

•
•

•
•

•

•

•

•
•
•
•
•
•
•

•
•
•
•
•
•
•

•

HELA cell line (Leibniz Institute DSMZ: Catalogue of Human and Animal 
Cell Lines (http://www.dsmz.de), cat. no. ACC-57) ! CAUTION The cell lines 
used in your research should be regularly checked to ensure that they are 
authentic and they are not infected with mycoplasma.
BS-C-1 cell line (ATCC, cat. no. CCL-26) ! CAUTION The cell lines used in 
your research should be regularly checked to ensure that they are authentic 
and they are not infected with mycoplasma.

DNA origami folding
Staple strands, modified and unmodified (Eurofins Genomics)
M13 bacteriophage ssDNA scaffold p7249 (New England BioLabs,  
cat. no. N4040S)
Tris, pH 8.0, 1 M (Ambion, cat. no. AM9856) ! CAUTION Tris can cause skin 
and serious eye irritation.
EDTA, pH 8.0, 0.5 M (Ambion, cat. no. AM9261) ! CAUTION EDTA may 
cause eye and skin irritation; avoid breathing the dust or fumes.
Water (Gibco, cat. no. 10977-035)
Magnesium, 1 M (Ambion, cat. no. AM9530G)
Agarose (Biomol, cat. no. 01280.100)
50× TAE Buffer (Fluka Analytical, cat. no. 67996-10L-F)
SYBR safe DNA gel stain (Invitrogen, cat. no. SS33102) ! CAUTION Protect 
your eyes and avoid breathing the dust, fumes or mist; it causes eye, skin 
and respiratory irritation.
DNA gel loading dye (Thermo Fisher Scientific, cat. no. R0611)
DNA ladder (Invitrogen, cat. no. 10787-018)

In vitro sample preparation
Protocatechuic acid (PCA; Sigma-Aldrich, cat. no. 37580-25G-F) ! CAUTION 
PCA causes skin, respiratory pathway and serious eye irritation. Avoid 
breathing the dust, fumes or mist.
Protocatechuate 3,4-dioxygenase (PCD; Sigma-Aldrich, cat. no. P8279-25UN)
Trolox (Sigma-Aldrich, cat. no. 238813-1G) ! CAUTION Trolox causes skin, 
respiratory pathway and serious eye irritation. Avoid breathing the dust, 
fumes or mist.
NaOH (VWR, cat. no. 31627.290) ! CAUTION NaOH causes serious skin 
and eye damage; avoid breathing the dust, fumes or mist. Wear protective 
equipment.
Methanol (Sigma-Aldrich, cat. no. 32213-2.5L) ! CAUTION Methanol is a 
flammable liquid, and it is toxic upon ingestion and skin contact; avoid 
breathing the dust, fumes or mist.
Potassium chloride (Carl Roth, cat. no. 6781.1)
Glycerol (Sigma-Aldrich, cat. no. 65516-500ml)
Isopropanol (Carl Roth, cat. no. 33539-2.5L-R) ! CAUTION Vapor and liquid 
phases are easily flammable, and the compound causes heavy eye irritation.
Epoxy Glue (Toolcraft, cat. no. TC-EPO5-24)
Albumin, biotin-labeled bovine (Sigma-Aldrich, cat. no. A8549-10MG)
Streptavidin (Thermo Fisher Scientific, cat. no. S888)
Tween 20 (Sigma-Aldrich, cat. no. p2287)

EQUIPMENT
Thermocycler (Mastercycler Nexus Gradient; Eppendorf, cat. no. 6331000017)
10-liter Tank (Carl Roth, cat. no. K653.1)
Sub-cell GT system gel chamber (Bio-Rad, cat. nos. 170 4401-4406 and  
170 4481-4486)
PowerPac basic power supply (Bio-Rad, cat. no. 1645050)
Microwave (Severin, cat. no. 7891)
Erlenmeyer flask, 250 ml (Carl Roth, cat. no. NY87.1)
Razor blade (Carl Roth, cat. no. CK07.1)
Visi-blue light transilluminator (UVP, cat. no. 95-0461-02)
Centrifuge 5430R (Eppendorf, cat. no. 5428000414)
NanoDrop 2000c (Thermo Fisher Scientific, cat. no. ND-2000c)
Shaker (GFL, cat. no. 3015)
Biological safety cabinet (HeraSafe; Thermo Electron Corporation,  
cat. no. 51022482)
Water purification system (PURELAB classic; ELGA LabWater,  
cat. no. CLXXUVFM2)
Incubator (Heracell 240; Thermo Fisher Scientific, cat. no. 51026333)
Pipetboy acu 2 (Integra, cat. no. 155017)
Eppendorf Research plus 0.1–2.5 µl pipette (Eppendorf, cat. no. 3120000011)
Eppendorf Research plus 0.5–10 µl pipette (Eppendorf, cat. no. 3120000020)
Eppendorf Research plus 2–20 µl pipette (Eppendorf, cat. no. 3120000038)
Eppendorf Research plus 10–100 µl pipette (Eppendorf, cat. no. 3120000046)
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http://www.dsmz.de
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Eppendorf Research plus 20–200 µl pipette (Eppendorf, cat. no. 3120000054)
Eppendorf Research plus 100–1000 µl pipette (Eppendorf, cat. no. 3120000062)
Multipette M4 pipette (Eppendorf, cat. no. 4982000314)
Eppendorf Research plus, 8-channel, 0.5–10 µl pipette (Eppendorf,  
cat. no. 3122000019)
Gel imager (Typhoon FLA 9500; GE, cat. no. 28996943)
Side cutter (Hoffmann Group, cat. no. 725310)
Amicon spin filters, 3 kDa (Merck/EMD Millipore, cat. no. UFC500396)
Amicon spin filters, 100 kDa (Merck/EMD Millipore, cat. no. UFC510096)
Nap5 columns (GE Healthcare, cat. no. 17-0853-02)
Zeba desalting spin columns (Thermo Fisher Scientific, cat. no. 89882)
Amicon spin filters, 100 kDa (Merck/EMD Millipore, cat. no. UFC510096)
NORM-JECT 2-ml syringe (Henke Sass Wolf, cat. no. 4020-000V0)
NORM-JECT 10-ml syringe (Henke Sass Wolf, cat. no. 4100-000V0)
NORM-JECT 20-ml syringe (Henke Sass Wolf, cat. no. 4200-000V0)
FINE-JECT Needle, 1.2 × 40 mm (Henke Sass Wolf, cat. no. 4710012040)
FINE-JECT Needle, 1.1 × 40 mm (Henke Sass Wolf, cat. no. 4710011040)
Silicon tubing, inner diameter = 0.5 mm, outer diameter = 1 mm (GM GmbH, 
cat. no. 35605)
T75 Flasks (Falcon, cat. no. 353136)
10-ml Serological pipettes (Greiner Bio-One, cat. no. 607180)
5-ml Serological pipettes (Greiner Bio-One, cat. no. 606180)
2-ml Serological pipettes (Falcon, cat. no. 357507)
Glass Pasteur pipettes (Brand, cat. no. 747720)
90-nm Gold particles (prepared in house83)
DNA LoBind Tube, 0.5 ml (Eppendorf, cat. no. 0030 108.035)
PCR tubes (Trefflab, cat. no. 96.09852.9.01)
Freeze ’N Squeeze columns (Bio-Rad, cat. no. 732-6165)
Aluminum foil (VWR, cat. no. 391-1257)
1.5-ml Eppendorf tubes (Eppendorf, cat. no. 0030 120.086)
15-ml Falcon tubes (Falcon, cat. no. 352096)
50-ml Falcon tubes (Falcon, cat. no. 352070)
ibidi sticky-Slide VI 0.4 (ibidi, cat. no. 80608)
High-precision cover glasses 18 × 18 mm, no. 1.5H (Marienfeld,  
cat. no. 0107032)
High-precision cover glasses 24 × 60 mm, no. 1.5H (Marienfeld,  
cat. no. 0107242)
Microscopy slide (Thermo Fisher Scientific, cat. no. 10756991)
Double-sided adhesive tape (Scotch, cat. no. 665D)
Weighing paper (VWR International, cat. no. 12578-121)

TIRF super-resolution setup
Optical air table (Newport, cat. no. RS4000-46-12)
Inverted fluorescence microscope (Nikon, Ti Eclipse with Perfect Focus System)
XY Stage (Physik Instrumente, cat. no. M-545.2MN)
Lenses and mirrors (Thorlabs)
Filter cubes (Chroma Technology, cat. nos. TRF49904-NK, TRF49909-NK, 
TRF49914-NK)
Oil-immersion objective, 100× Apo SR TIRF objective, numerical aperture 
(NA) = 1.49, working distance (WD) = 0.12 (Nikon)
Immersion oil, refractive index (n) = 1.515 (23 °C), (Nikon, Type A)
sCMOS camera (Hamamatsu Orca Flash 4.0 V2)
EMCCD camera (Andor, iXon Ultra, model no. DU-897)
Excitation laser, 488 nm, 200 mW (Toptica iBeam smart, model no.  
488-S-HP)
Excitation laser, 561 nm, 200 mW (Coherent Sapphire, model no. 561-200 
CW CDRH)
Excitation laser, 640 nm, 150 mW (Toptica, iBeam smart, model no. 640-S)
Microscopy slide thermal power sensor (Thorlabs, model no. S170C)
Digital power meter (Thorlabs, model no. PM100D)
Acquisition computer: a computer used to acquire microscope data with 
the µManager software package58. See EQUIPMENT SETUP for hardware 
requirements.
Analysis computer: a computer with a Microsoft Windows 64-bit operating 
system. See EQUIPMENT SETUP for hardware requirements.
Analysis software: our analysis software package ‘Picasso’ can be downloaded  
from our website at http://www.jungmannlab.org.

REAGENT SETUP
Pre-extraction buffer  The pre-extraction buffer consists of 0.4% (vol/vol) 
glutaraldehyde and 0.25% (vol/vol) Triton X-100 in 1× PBS at pH 7.2. It can be 
stored at −20 °C for 12 months.
Enhanced microtubule fixative  The enhanced microtubule fixative consists 

•
•
•
•

•
•
•
•
•
•
•
•
•
•
•
•
•

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

•

•
•
•

•
•
•
•
•

•

•
•
•
•

•

•
•
•
•

•

•

of 3% (vol/vol) glutaraldehyde in 1× PBS at pH 7.2, and it can be stored at 
−20 °C for 12 months.
Standard fixative  The standard fixative consists of 3% (vol/vol)  
paraformaldehyde and 0.1% (vol/vol) glutaraldehyde in 1× PBS at pH 7.2.  
It can be stored at −20 °C for 12 months.
Blocking solution  The blocking solution contains 3% (wt/vol) BSA and 
0.2% (vol/vol) Triton X-100 in 1× PBS at pH 7.2, and it must be filter- 
sterilized. It can be stored at 4 °C for up to 6 weeks.
Antibody dilution solution  The antibody dilution solution contains 3% 
(wt/vol) BSA in 1× PBS at pH 7.2, and it must be filter-sterilized. It can be 
stored at 4 °C for up to 6 weeks.
DTT solution  The DTT solution consists of 250 mM DTT, 1.5 mM EDTA 
and 0.5× PBS, pH 7.2. It must be freshly prepared for the reduction of the 
thiolated DNA.
BCA mix  The BCA mix includes 500 µl of reagent A, 500 µl of reagent B and 
25 µl of reagent C (from the Micro BCA Protein Assay Kit), and it must be 
freshly prepared.
HeLa cell medium  The HeLa cell medium consists of MEM, 10% (vol/vol) 
FCS, 1% (vol/vol) P/S, 2 mM l-glutamine and 1× non-essential amino acids. 
HeLa cell medium can be stored at 4 °C for up to 4 months.
BSC1 cell medium  The BSC1 cell medium consists of EMEM, 10% (vol/vol) 
FCS and 1% (vol/vol) P/S.
Cross-linker aliquots  Cross-linkers should be divided into aliquots at a 
concentration of 10 mg/ml in DMF, and they can be stored at −80 °C for up 
to 12 months.
Buffer A  Buffer A consists of 10 mM Tris-HCl and 100 mM NaCl at pH 8.0, 
and it can be stored at room temperature (RT; 21 °C) for 6 months.
Buffer A+  Buffer A+ consists of 10 mM Tris-HCl, 100 mM NaCl and 0.05% 
(vol/vol) Tween 20 at pH 8.0, and it can be stored at RT for 6 months.
Buffer B  Buffer B consists of 5 mM Tris-HCl, 10 mM MgCl2 and 1 mM 
EDTA at pH 8.0, and it can be stored at RT for 6 months.
Buffer B+  Buffer B+ consists of 5 mM Tris-HCl, 10 mM MgCl2, 1 mM EDTA 
and 0.05 % (vol/vol) Tween 20 at pH 8.0, and it can be stored at RT for 6 months.
Buffer C  Buffer C consists of 1× PBS at pH 7.2 supplemented with addi-
tional 500 mM NaCl, and it can be stored at RT for up to 6 months.
Exchange washing buffer  Exchange washing buffer consists of Buffer B+ for 
in vitro samples and of 1× PBS, pH 7.2, for in situ samples; it can be stored at 
RT for 6 months.
100× Trolox solution  100× Trolox solution consists of 100 mg of Trolox, 430 µl 
of methanol and 345 µl of NaOH (1 M) in 3.2 ml of H2O. It should be divided 
into 20-µl portions in PCR tubes and can be stored at −20 °C for up to 6 months.
40× PCA solution  40× PCA solution consists of 154 mg of PCA in 10 ml of 
water, adjusted to pH 9.0 with NaOH. The solution should be divided into 
20-µl aliquots in PCR tubes and can be stored at −20 °C for up to 6 months.
100× PCD solution  100× PCD solution consists of 9.3 mg of PCD and  
13.3 ml of buffer (50% glycerol stock in 50 mM KCl, 1 mM EDTA and  
100 mM Tris–HCl, pH 8.0). It should be divided into 20-µl aliquots in PCR 
tubes and can be stored at −20 °C for up to 6 months.
Oxygen-scavenging system PPT solution  PPT solution consists of a 1:1:1 
ratio of 1× PCA/1× PCD/1× Trolox. Mix with imaging buffer at least 1 h 
before imaging.
Imager solution  For in vitro samples, the imager solution consists of 1× 
Buffer B+, optional scavenger system PPT solution (1× Buffer B+, 1× PCA, 
1× PCD, 1× Trolox) and a fluorophore-labeled DNA strand. For in situ  
samples, the imager solution consists of 1× Buffer C, optional scavenger 
system PPT solution (1× Buffer C, 1× PCA, 1× PCD, 1× Trolox)  and a 
fluorophore-labeled DNA strand. The concentration range for the fluorophore-
labeled DNA strand is highly target dependent, but it ranges between 100 pM 
and 10 nM. The solution should always be freshly prepared.
10× Folding buffer  10× folding buffer consists of 125 mM MgCl2, 100 mM 
Tris and 10 mM EDTA at pH 8.0, and it can be stored at RT for up to 6 months.
Gel buffer  Gel buffer consists of 1× TAE buffer, and it can be stored at RT 
for 1 year.
Gel running buffer  Gel running buffer consists of 1× TAE buffer and  
12.5 mM MgCl2, and it can be stored at RT for up to 1 year.
BSA–biotin stock  BSA–biotin stock contains 10 mg/ml BSA–biotin in Buffer 
A, and it should be divided into 20-µl aliquots. It can be stored at −20 °C for 
up to 6 months.

http://www.jungmannlab.org


©
20

17
 M

ac
m

ill
an

 P
u

b
lis

h
er

s 
L

im
it

ed
, p

ar
t 

o
f 

S
p

ri
n

g
er

 N
at

u
re

. A
ll 

ri
g

h
ts

 r
es

er
ve

d
.

© 2017 Macmillan Publishers Limited, part of Springer Nature. All rights reserved.

protocol

1214 | VOL.12 NO.6 | 2017 | nature protocols

BSA–biotin solution  BSA–biotin solution contains 1 mg/ml BSA–biotin  
in Buffer A+ and should be freshly prepared. It can be stored for up to  
3 d at 4 °C.
Streptavidin stock  Streptavidin stock contains 10 mg/ml streptavidin in 
Buffer A and should be divided into 10-µl aliquots. It can be stored at −20 °C 
for up to 6 months.
Streptavidin solution  Streptavidin solution contains 0.5 mg/ml streptavidin in 
Buffer A+ and should be freshly prepared. It can be stored for up to 3 d at 4 °C.
Staple strands  Staple strands can be ordered in different purity grades. 
High-purity salt-free purification is sufficient for standard staples; however, 
we recommended ordering modified staples, such as those with fluorophores 
or biotins, HPLC or PAGE purified. Staple strands for nanostructures  
should be ordered in 96-well plates (0.2 ml) to facilitate the handling and 
creation of master mixes with the help of multipipettes. To keep the manual 
handling to a minimum, the staples should be ordered prediluted at a 
 concentration of 100 µM in H2O. The plates can be stored at −20 °C for  
at least 12 months.
EQUIPMENT SETUP
Acquisition computer  The following computer system was used for all data 
acquisition in this protocol: Dell Precision T7910, Dual Intel Xeon Processor 
E5-2620 v3 at 2.4 GHz (12 cores), 32 GB RAM, four 2 TB HDD configured 
in a Hardware RAID 0, Windows 7 Professional 64-bit operating system.  
 CRITICAL A RAID 0 setup is optimized for fast input/output. For long-term 
data storage, users are advised to use data storage facilities with daily backup 
available to research groups at universities or research institutes.

Acquisition software  As image acquisition software, install µManager, an 
open-source software58 that can be downloaded from https://micro-manager.org.  
Follow the installation instructions and set up the software to control the 
microscope equipment.
Analysis computer  We do recommend performing all postacquisition steps 
with Picasso on a separate analysis workstation. The hardware requirements 
depend on the specific file size of the data set to be analyzed. Generally, the most 
important factors are the number of available CPU cores and RAM. The follow-
ing system was used for all analyses in this protocol: Dell Precision T7910, Dual 
Intel Xeon CPU E5-2680 v3 at 2.5 GHz (24 cores), 256 GB RAM and four 2 TB 
HDD configured in a Hardware RAID 0, Windows Server 2012 R2 64-bit  
operating system.  CRITICAL A RAID 0 setup is optimized for fast input/output. 
For long-term data storage, users are advised to use data storage facilities with 
daily backup available to research groups at universities or research institutes.
Analysis software  Download the ‘Picasso’ installer available at our website 
(http://www.jungmannlab.org). Follow the installation instructions. Multiple 
Picasso components will appear as shortcuts in a start menu subfolder 
named ‘Picasso’.
Power density calibration  Determine the laser power at the sample by 
placing the microscopy slide thermal power sensor with immersion oil on 
the sample holder. The power density is then calculated as an average density 
over the illuminated area. See Supplementary Table 1 for an exemplary 
calibration on our microscope.
Fluid exchange chamber  To prepare a fluid exchange chamber for in situ 
imaging, see Box 1.

PROCEDURE
Design of DNA nanostructures ● TIMING 1 h
1|	 Start ‘Picasso: Design’, which displays a canvas of a hexagonal lattice, representing the staple strand positions  
(Fig. 6) in a 2D RRO33.

2|	 Design a pattern of DNA-PAINT binding sites by clicking on the canvas hexagons. Clicking on a hexagon will change  
its color and marks the respective staple to be extended with an external sequence. Each color corresponds to a specific 
extension that may be defined later. The default state without an external extension is indicated by a gray hexagon.  
The center-to-center distance between two hexagons is ~5 nm on the DNA origami. To change the ‘current color’, click on  
a colored hexagon in the color palette to the right. Clicking on a hexagon with a currently selected color will reset the  
‘current color’ to the unmarked state (gray). Click ‘Clear’ to reset all hexagons in the lattice. The eight white double-hexagons 
within the structure are placeholders for biotinylated staples for surface attachment and are not intended for modification. 
In total, the structure consists of 176 staples available for modification.

3|	 Click ‘Save’ to save the design. Progress can be saved at any time and loaded at a later point by selecting ‘Load’.  
A screenshot of the design can be saved by clicking on ‘Screenshot’.

4|	 Click on ‘Extensions’ to specify the extensions corresponding to each color. A table with all the colors present in the  
design will open. A selection of commonly used DNA-PAINT handles can be obtained via the dropdown menu in the ‘Preselection’  
column. This list can be extended by modifying ‘paint_sequences.csv’ in the subfolder ‘picasso’ of the Picasso install directory. 
See Supplementary Table 2 for a table of the default sequences. Alternatively, define a custom ‘Shortname’ and ‘Extension’ 
by entering them in the table. After defining all colors used in the canvas, select ‘OK’ to confirm the extensions. The display 
will update with the ‘Shortname’. The sequence specified will be added to the 3′-end of the staple and will point out of the 
structure (away from the cover glass). For a full list of all unmodified core staples, refer to Supplementary Table 3.

5|	 Once the design step is complete, the sequences for the corresponding structure need to be obtained. Click on ‘Get 
plates’ to generate a staple list for ordering. As an RRO origami structure consists of 184 staples, the staples in the list are 
arranged in two 96-well plates, so that each well corresponds to a position on the hexagonal lattice. It is possible to export 
only the sequences of a particular structure (in total, two plates) or to get a list of plates for which all possible positions 
are extended with all extensions used in the design. This is particularly useful in the case in which different origami designs 
with different extensions and patterns will be tested, so all staples are ready to be mixed and matched for subsequent  
design iterations. The software will export the list in .csv format, so that the file can be used for direct ordering at your 
favorite oligo synthesis company. Choose high-purity salt-free purification and order oligonucleotides in solution with a 

https://micro-manager.org
http://www.jungmannlab.org
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concentration of 100 µM in H2O (see also Reagent Setup). Store the .csv file in a folder so that the program can later create 
pipetting schemes based on your plate stock. In addition, order the biotinylated staples (for cover glass attachment of the 
DNA origami) that can be found in Supplementary Table 4.
 PAUSE POINT Typically, synthesis of unmodified oligonucleotides at a commercial vendor will take between 2 and  
10 working days.

Folding of DNA structures ● TIMING 6–7 h
6|	 Once all sequences are obtained, staples with the same extension are pooled together from plates and place in micro-
centrifuge tubes as stock mixes. Picasso will generate a visual pipetting aid to help identify which staples need to be pooled 
together in a separate microcentrifuge tube. To so initiate this, select ‘Pipetting scheme’ and select the folder with all 
previously generated plates. ‘Picasso: Design’ will search in all .csv files in that folder for sequences that are needed for the 
design. Note that only .csv files that contain staple lists (that were generated with ‘Get plates’ in ‘Picasso: Design‘) should 
be present in that folder. A list will be generated with all necessary sequences and the visual pipetting aid in .pdf format for 
the origami stock mixes. The dimensions of the printed pipetting scheme match those of typical 96-well plates, so that wells 
that need to be pipetted can be easily identified.
 CRITICAL STEP If the software does not find all sequences that are needed in the plate list, it will display an error 
message but still compile the pipetting aid and the staple list. Missing staples are indicated by ‘NOT FOUND’ in the list.

7|	 Print out the pipetting aid and place a transparent 96-well plate above it. Pool staples according to their color and 
the pipetting aid for stock mixes in microcentrifuge tubes. The volume of each staple that is needed when pooling can be 
estimated considering the final amount of structures. When folding, i.e., 40 µl of DNA origami with a 10-nM final scaffold 
concentration (enough for ~80 DNA-PAINT experiments), the amount of staples needed is ~0.04 µl for each core staple and 
~0.4 µl for each extended staple. As pipetting precision decreases with small volumes, pipette at least 1 µl per staple when 
pooling for mixes. Avoid contamination of the plates, do not talk while pipetting and cover the plates whenever possible. 
Seal the plates immediately after use. Store mixes at −20 °C in tubes for up to 12 months.

8|	 Select ‘Folding Scheme’ to generate a table with a folding protocol. Adjust the initial concentrations in the table  
according to the ordered stocks and click ‘Recalculate’, if applicable. The software will automatically calculate the  
concentration of a strand in a staple mix depending on the number of staples in the mix. Adjust ‘Excess’ or ‘Total Volume’  
to your needs and mix all items on the folding scheme list in the calculated quantities. Refer to Supplementary Table 5  
for n exemplar folding table.

9|	 Use a thermocycler and fold the origami mix using the following thermal gradient:

Cycle number Parameters

1 80 °C

2–57 60 °C–4 °C, 3 min 12 s per °C

58 Hold at 4 °C

 PAUSE POINT The structures can be stored at 4 °C for up to 1 week or at −20 °C in DNA LoBind Tubes for long-term storage 
(at least several months).

Purification of DNA nanostructures ● TIMING ~3.5 h
10| Purify the DNA nanostructures using your favorite method. Several methods for purification of DNA nanostructures,  
such as Gel42, rate-zonal centrifugation43 and PEG44, are described in the literature. For DNA-PAINT, it is possible in most 
cases to use the structures without purification, as excess staple strands will be washed out of the flow chamber.
 CRITICAL STEP When folding DNA origami for the first time, it is recommended to run an agarose gel to confirm the  
folding (Fig. 6). Typically, well-folded monomeric structures will appear as a single sharp gel band (upper highlighted area  
in the gel in Fig. 6) together with a faster migrating band consisting of excess staple strands (lower highlighted area in the 
gel in Fig. 6).
 PAUSE POINT The structures can be stored at 4 °C for up to 1 week or at −20 °C in DNA LoBind Tubes for at least 1 year.

11| Prepare a solution of 1.8 g of agarose in 120 ml of gel buffer in an Erlenmeyer flask (1.5% (wt/vol)).
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12| Use a microwave to heat up and completely solubilize the agarose solution by stirring the flask in between the heating phases.
! CAUTION Use heat-resistant gloves when handling the hot flask to avoid burns.

13| If no agarose particle traces are visible anymore, let the solution cool for 1 min, and add 1.5 ml of 1M MgCl2 and 14 µl 
of Sybr Safe.
! CAUTION Avoid inhaling solutions with Sybr Safe.

14| Pour the solution into a gel chamber, add an appropriate comb and let it solidify for 45 min.

15| Load the gel with the DNA origami structures. Prepare two lanes for a DNA ladder and scaffold (same concentration  
as origami) as reference. Mix the origami solution with loading dye (20 µl of folded DNA Origami + 5 µl of loading dye) and 
run the gel in running buffer at 90 V for 90 min at 4 °C or on ice.

16| Acquire an image using a gel imager for documentation.

17| Cut out the origami band with a razor blade on a blue-light transilluminator table. The origami band should appear as  
a distinct band with a slight shift as compared with the scaffold. Excess staples will have created a broader band that 
traveled further. Crush the gel piece with a pestle, transfer it to a Freeze ’N Squeeze column, and spin it for 6 min at 1,000g 
at 4 °C. Keep the flow-through and discard the filter.
? TROUBLESHOOTING
 PAUSE POINT The origami can be stored at 4 °C for 1 week or at −20 °C in LoBind tubes for long-term storage.

Preparation of DNA origami for DNA-PAINT imaging ● TIMING ~45 min
18| There are two options for preparing microscopy slides. See option A for the preparation in a custom-built flow chamber 
that will be sealed after immobilization of structures and addition of imager solution. For Exchange-PAINT experiments that 
require fluid exchange, see option B for preparation in an open chamber. The process of making custom-built chambers is 
also depicted in Supplementary Figure 10.
(A) Immobilization in a custom-built chamber
	 (i) �Clean the microscopy slide and the cover glass with isopropanol and dry it with lab wipes.
	 (ii) �Prepare a flow chamber by taping two stripes of double-sided adhesive tape ~8 mm apart on the microscopy slide and 

form a flow chamber by placing a cover glass on top. The resulting channel will have a volume of ~20–30 µl. Use a 
pipette tip and press the cover glass firmly against the sticky tape. The sticky tape will appear darker when the cover 
glass is in good contact. 
 CRITICAL STEP Do not use excessive force, as the glass may break.

	 (iii) �Remove excess adhesive tape by pulling the tape over the edges of the cover glass.
	 (iv) �Fill the chamber with 20 µl of BSA–Biotin solution (1 mg/ml) and incubate it for 2 min.
	 (v) �Wash the channel with 40 µl of Buffer A+ by holding the tip of a folded lab wipe on one end of the channel and  

simultaneously pipetting in washing buffer on the other side. The capillary forces of the tissue will suck the liquid 
out of the chamber, whereas the pipetting will introduce additional volume. Control the flow by variation of pipetting 
speed and tissue pressure. 
 CRITICAL STEP Avoid bubbles by keeping an even flow. Do not let the chamber dry out. Practice with an empty 
slide and water if necessary.

	 (vi) �Add 20 µl of streptavidin solution (0.5 mg/ml) to the channel and incubate it for 2 min.
	 (vii) �Wash the channel with 40 µl of Buffer A+.
	(viii) �Wash the channel with 40 µl of Buffer B+.
	 (ix) �Add 20 µl of (5 µl of gel-purified DNA origami and 15 µl of Buffer B+) origami solution and incubate for 2 min. 

? TROUBLESHOOTING
	 (x) �Wash the channel with 40 µl of Buffer B+.
	 (xi) �Add 20 µl of imager solution to the channel. 

 CRITICAL STEP Imager concentration has a critical role in proper acquisition of DNA-PAINT data. For in vitro  
samples, consider an ~5 nM imager concentration for a DNA nanostructure with 12 binding sites as a start value.

	 (xii) �(Optional) For spectral multiplexing, use 2 different DNA sequences with spectrally distinct fluorophores, such as  
Cy3B and Atto655.

	(xiii) �Use epoxy glue to seal the chamber. Pour the glue on a piece of weighing paper, mix with a pipette tip and distribute 
the glue evenly on the edges of the cover glass. Once the chamber is sealed, place the pipette tip standing up in the 
remaining epoxy to later evaluate the glue dryness.
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	(xiv) �Wait for ~15 min for the epoxy to dry. The drying process can be evaluated by checking the pipette tip in the epoxy. 
Once the epoxy is completely dry, the pipette tip should stick. The sample is now ready for imaging. 
 CRITICAL STEP Wait until the epoxy is completely dry to avoid glue contamination of the microscope objective.

(B) Immobilization in a 6-channel ibidi sticky-Slide
	 (i) �Clean the cover glass (24 × 60 mm) with isopropanol and dry it with lab wipe.
	 (ii) �Attach the cover glass upside down to the sticky-Slide and press it with the help of a pipette tip against the cover glass.
	 (iii) �Add 80 µl of BSA–biotin solution to the channel. Tilt the slide slightly to ensure that the chamber is completely  

filled and incubate it for 5 min.
	 (iv) �Wash the channel with 180 µl of Buffer A+ by pipetting the solution into one opening and pipetting out 180 µl  

from the opposing opening.
	 (v) �Incubate 40 µl of streptavidin solution twice for 5 min.
	 (vi) Wash the channel with 180 µl of Buffer A+.
	 (vii) Wash the channel with 180 µl of Buffer B+.
	(viii) �Icubate the DNA origami solution (20 µl of gel-purified DNA origami + 60 µl of Buffer B+) for 20 min. 

? TROUBLESHOOTING
	 (ix) �Wash the channel two times with 100 µl of Buffer B+.
	 (x) �Add Imager strand solution to the sample for imaging. 

 CRITICAL STEP Imager concentration has a critical role in proper acquisition of DNA-PAINT data.  
For in vitro samples, consider ~5 nM for DNA nanostructures with 12 binding sites as a start value. (Optional)  
For spectral multiplexing, use two different DNA sequences with spectrally distinct fluorophores, such as  
Cy3B and Atto655.

	 (xi) �Put the lid back on the chamber. The sample is now ready for imaging.

Sample preparation for in situ samples
19| Generate DNA-conjugated secondary antibodies. Here, two methods are presented: option A describes the use of a  
maleimide-PEG2-succinimidyl ester cross-linker, which links free amino groups on the protein to reduced thiolated DNA22, 
and option B describes the use of a DBCO-sulfo-NHS ester, which binds to amino groups on the protein and via copper-free  
click chemistry to an azide-modified DNA strand55. The copper-free click chemistry allows for conjugation of multiple 
antibody species in parallel, whereas the attachment via Maleimide chemistry is more cost-effective, considering the DNA 
components. The reduction of the thiol group and the subsequent purification of the DNA from DTT using the Nap-5 column 
is time-consuming and time-critical. Long waiting times will lead to disulfide bridging of the DNA strands. The copper-free 
click chemistry in comparison does not have such a time-consuming and time-critical step in regard to the reagent stability, 
and therefore allows for parallel labeling of the antibodies. Alternatively, DNA-labeled antibodies can also be obtained from 
Ultivue (http://www.ultivue.com).
(A) DNA labeling of antibodies via maleimide-PEG2-succinimidyl ester for cellular labeling ● TIMING 1 d 1 h
	 (i) �To reduce the thiolated DNA for the Maleimide reaction, mix 30 µl of 1-mM thiolated DNA with 70 µl of freshly  

prepared DTT solution and incubate the mixture on a shaker for 2 h at RT covered with aluminum foil.
	 (ii) �Concentrate the antibody using Amicon spin filters (100 kDa). Wash the filters with 1× PBS for 10 min at 14,000g  

at 4 °C. Discard the flow-through, add 300 µl of antibody solution and spin at 14,000g for 5 min at 4 °C. Discard the  
flow-through and invert the spin filter in an empty tube. Spin for 6 min at 1,000g at 4 °C. Adjust the volume to 100 µl  
with 1× PBS, and measure the concentration with the NanoDrop spectrophotometer. Keep the antibody on ice. The final 
concentration should be >1.5 mg/ml.

	 (iii) �Prepare the cross-linker solution in 1× PBS and add it to the antibody in a 10:1 molar ratio. Incubate the solution  
for 90 min at 4 °C on a shaker covered in aluminum foil. Start the reaction 1 h after the DNA reduction step  
was started. 
 CRITICAL STEP The desired amount of cross-linker must be no more than 5 µl in volume in order to avoid adding 
too much of DMF or diluting the antibody further.

	 (iv) �20 min before the DNA reduction step is completed, start to equilibrate a Nap-5 column with ddH2O filled to the  
top three times. Add DNA–DTT solution to the column and immediately add 400 µl of ddH2O. After 400 µl has passed 
through, add 1 ml of ddH2O and start collecting fractions immediately. Collect three drops in the first four tubes,  
two drops in the following four and one drop in the last eight tubes. Starting from the last collected tube, add 25 µl 
of BCA mix to the tubes. If DTT is still present, the solution turns purple. Discard those tubes. If no color change  
is visible anymore, discard the next tube as well and measure the concentration of the remaining fractions via the  
NanoDrop spectrophotometer. Pool the fractions with the highest concentrations. The highest fractions will have a  
DNA concentration between 200 and 800 ng/µl. 
 CRITICAL STEP If DTT is still present in the DNA solution, it will interfere with the Maleimide reaction.

http://www.ultivue.com
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	 (v) �Concentrate the reduced DNA using Amicon spin filters (3 kDa). Wash the filter with 1× PBS for 30 min at 14,000g  
at 4 °C. Discard the flow-through and add the pooled fractions of reduced DNA to the filter. Centrifuge for 30 min  
at 14,000g at 4 °C and discard the flow-through. Invert the spin filter in an empty new tube and spin for 6 min at 
1,000g at 4 °C. Measure the concentration with the NanoDrop spectrophotometer; the DNA should have a concentra-
tion >700 ng/µl.

	 (vi) �After the antibody–cross-linker reaction has completed, use a Zeba desalting column to remove the linker. Remove the 
storage solution by centrifugation at 1,500g for 1 min at 4 °C. Mark the side where the resin slid up, and perform the 
subsequent centrifugation steps in the same orientation. Wash the Zeba column with 300 µl of PBS and centrifuge it 
at 1,500g for 1 min at 4 °C. Dry the bottom of the column and use a fresh 1.5-ml tube. Add the antibody–cross-linker 
solution to the Zeba column, and spin at 1,500g for 2 min at 4 °C. Discard the Zeba column, retain the flow-through 
and measure the concentration with the NanoDrop spectrophotometer. The antibody concentration should be > 1.5 
mg/ml.

	 (vii) �Incubate a 10:1 molar ratio of thiolated DNA to antibody overnight on a shaker covered in aluminum foil in  
a cold room.

	(viii) �Remove excess DNA by Amicon spin filtration (100 kDa). For this, wash the filters with 1× PBS for 10 min at 14,000g 
at 4 °C. Discard the flow-through, add antibody–DNA solution, add 300 µl PBS and spin at 14,000g for 5 min at 4 °C. 
Discard the flow-through and invert the spin filter into an empty tube. Spin the solution for 6 min at 1,000g at 4 °C. 
Adjust the volume to 100 µl with 1× PBS, and measure the concentration with the NanoDrop spectrophotometer.  
The peak signal should be shifted toward 260 nm from 280 nm, and the concentration should be >5 mg/ml because  
of the stronger absorbance of DNA. Keep the antibody on ice and store it at 4 °C for a maximum of 6 months. 
? TROUBLESHOOTING

(B) Labeling via DBCO-sulfo-NHS ester ● TIMING 4 h
	 (i) �Concentrate the antibody using Amicon spin filters (100 kDa). For this, wash the filters with 1× PBS for 10 min at 

14,000g at 4 °C. Discard the flow-through, add 300 µl of antibody solution and spin at 14,000g for 5 min at 4 °C.  
Discard the flow-through and invert the spin filter in an empty tube. Spin for 6 min at 1,000g at 4 °C. Adjust the  
volume to 100 µl with 1× PBS, and measure the concentration with the NanoDrop spectrophotometer. Keep the  
antibody on ice. The final concentration should be >1.5 mg/ml.

	 (ii) �Prepare 5 µl of cross-linker solution in 1× PBS so that the final solution after addition of 100 µl of the antibody  
contains a 10:1 molar ratio of cross-linker to antibody. Incubate the solution for 90 min at 4 °C on a shaker covered  
in aluminum foil.

	 (iii) �After the antibody–cross-linker reaction is completed, use a Zeba desalting column to remove the linker. Remove the 
storage solution by centrifugation at 1,500g for 1 min at 4 °C. Mark the side where the resin slid up, and perform the 
subsequent centrifugation steps in the same orientation. Wash the Zeba column with 300 µl of 1× PBS at 1,500g for  
1 min at 4 °C. Dry the bottom of the column and use a fresh 1.5-ml tube. Add antibody–cross-linker solution to the 
Zeba column and spin it at 1,500g for 2 min at 4 °C. Discard the Zeba column, retain the flow-through and measure 
the concentration on the NanoDrop spectrophotometer. The antibody concentration should be >1.5 mg/ml.

	 (iv) �Create a 15:1 molar ratio of DNA to antibody and incubate the solution for 1 h at RT on a shaker covered in aluminum 
foil.

	 (v) �Remove the excess DNA by Amicon spin filtration (100 kDa). For this, wash the filters with 1× PBS for 10 min at 
14,000g at 4 °C. Discard the flow-through, add antibody-DNA solution, add 300 µl of 1× PBS and spin at 14,000g for 
5 min at 4 °C. Discard the flow-through and invert the spin filter in an empty tube. Spin for 6 min at 1,000g at 4 °C. 
Adjust the volume to 100 µl with 1× PBS, and measure the concentration with the NanoDrop spectrophotometer.  
The peak signal should be shifted toward 260 nm from 280 nm, and the concentration should be >5 mg/ml because  
of the stronger absorbance of DNA. 
? TROUBLESHOOTING
 PAUSE POINT Keep the antibody on ice and store it at 4 °C for a maximum of 6 months.

Immunofixation of cells ● TIMING 2.5 d
 CRITICAL In Steps 20–33, we describe procedures for immunofixation optimized for DNA-PAINT super-resolution micros-
copy. Fixation strategies depend on the target of interest, as well as on the antibody-recognition motifs57.
20| Seed 30,000 cells in 8-well chambered cover glasses, and let them grow overnight at 37 °C and 5% CO2 in an incubator.

21| After 24 h, the cells are ready to be fixed.

22| In this step, fixative is added to the cells; this can be performed in two ways: option A, an optimized protocol for maximum 
preservation of cellular cytoskeletal structures (recommended for imaging microtubules) and option B, a standard protocol.
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(A) Optimized microtubule fixation
	 (i) �Pre-extract the cells with prewarmed (37 °C for 10 min) pre-extraction buffer for 90 s.
	 (ii) �Remove the extraction buffer and fix the cells for 15 min in prewarmed enhanced microtubule fixative.
(B) Standard fixation
	 (i) �Fix the cells in standard fixative for 15 min.

23| Aspirate the fixative solution and reduce the sample with 1 mg/ml sodium borohydride for 7 min.
 CRITICAL STEP Sodium borohydride must be prepared just before application to the sample and is very volatile.

24| Wash the chamber four times (1 × 20 s, 3 × 5 min) with 1× PBS at pH 7.2.

25| Block and permeabilize the cell sample in blocking buffer for 90 min at RT.

26| Dilute the primary antibody according to supplier instructions in antibody dilution buffer, and incubate the sample  
at 4 °C overnight on a rocking platform.

27| Wash the sample three times for 5 min in 1× PBS.

28| Dilute DNA-labeled secondary antibody (5–50 µg/ml) in antibody dilution buffer, and apply it to the sample  
for 60 min. (Optional) For multiplexing experiments, use different secondary antibodies with orthogonal DNA handles;  
see Supplementary Table 2 for recommended sequences.

29| Wash the sample three times for 5 min in 1× PBS.

30| Dilute 90-nm gold particles at a 1:10 ratio in PBS as fiducial markers and incubate for 5 min on the cell sample.

31| Wash the sample three times for 5 min in 1× PBS.

32| Add a target-specific imager solution to the sample.
 CRITICAL STEP Imager concentration has a critical role in proper acquisition of DNA-PAINT data. The concentration should 
be adjusted for the target (hence docking strand) density. For microtubules, we recommend starting with a 500 pM imager 
strand concentration and adjusting as necessary.

33| (Optional) For multiplexed Exchange-PAINT experiments, place the exchange lid with the connected tubing on the  
chambered cover glass.

Data acquisition ● TIMING 10 min to 10 hours
 CRITICAL The following section describes the procedure for performing DNA-PAINT experiments using imager sequences 
labeled with Cy3B fluorophores. As the SNR for DNA-PAINT is rather high, both CCD or sCMOS cameras are suitable for  
imaging. The procedure is written for use of an iXon Ultra DU-897 EMCCD camera, although electron-multiplying is not  
necessary. Considerations in regard to acquisition of images with ultra-high resolution are described in Box 2. For test  
purposes, raw DNA-PAINT data can also be simulated in silico with ‘Picasso: Simulate’ (see Box 3 for procedure details).
34| Place the sample on the microscope stage, and move the objective up until the immersion oil touches the sample.

35| (Optional) For multiplexing with Exchange-PAINT, attach tubing with syringes to the exchange chamber. Consider using 
an ~15-ml syringe volume of exchange buffer per exchange round for in situ exchange experiments, and ~1 ml of exchange 
buffer per exchange round for in vitro experiments. For in situ experiments, additionally attach tubing to the chamber inlet. 
Put the connected syringes into plastic trays to avoid accidental fluid spills. The syringes should be at the same level as the 
chamber to avoid liquid exchange, as they are communicating vessels.
 CRITICAL STEP Handle liquids extremely carefully if they are close to the microscope. Improper handling and leakage can 
lead to damage of delicate microscope components.

36| Start µManager, select the configuration file for the camera and select ‘Ok’. The main window of µManager will open.

37| Set ‘Exposure [ms]’ with regard to the following considerations: exposure times for DNA-PAINT experiments are dependent  
on the imager length and concentration, the imaging buffer and the docking strand density of the target structure. Typical 
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exposure times for 9-bp DNA duplexes are hundreds of milliseconds, and those for 8-bp DNA duplexes are tens of  
milliseconds, as they have a shorter ON-time. For the samples used in Figure 1, an exposure time of 300 ms for in vitro 
(Buffer B+) and 200 ms for in situ (Buffer C) samples was used. ‘Picasso: Simulate’ can be used to determine ideal exposure 
times for given sample parameters. As a general rule of thumb, camera integration times should be matched to mean  
ON-times of DNA-PAINT imager/docking duplexes for best performance; these can be experimentally determined using  
Picasso (see Step 69B). Refer to Supplementary Table 6 for the acquisition settings used for the images in this protocol.

38| Open ‘Tools’ > ‘Device Property Browser’.

39| Set the camera parameters: set ‘Output_Amplifier’ to ‘Conventional’, set ‘Region of Interest’ to ‘Full Image’, set ‘Frame 
Transfer’ to ‘On’, set ‘PixelType’ to ‘16bit’, set ‘ReadMode’ to ‘Image’ and set ‘Camera shutters’ to ‘Open’.

40| Click on ‘Live’ in the main window, and the ‘Snap/Live’ window will appear. Select ‘Autostretch’ in the contrast settings. 
The ‘Snap/Live’ window should show background noise.

41| Set the laser to a low power density of 0.25 kW/cm2 at the sample plane (refer to the calibration as performed in the 
Equipment Setup), and open the laser shutter.
? TROUBLESHOOTING

42| Focus the image.
 CRITICAL STEP A focused image should show blinking diffraction-limited spots, each representing the binding and  
unbinding of an imager strand to its target. Adjust the contrast by dragging the black and white triangles in the ‘Contrast’ 
window if needed. For prefocusing, preferably use a focus-lock system such as the Nikon Perfect Focus System or, in case of  
in situ samples, prefocus with the bright-field image.
? TROUBLESHOOTING

43| Increase the laser power to a power density of ~ 2.5 kW/cm2 at the sample plane.

44| Adjust the laser incident angle. When starting in an epifluorescence configuration, increase the angle until  
total internal reflection occurs. Continue until no more light is reflected and the signal decreases. Then, go back by  
decreasing the angle and optimize the SNR. When imaging structures beyond the TIRF illumination range, decrease the  
incident angle—potentially moving to oblique (HILO) illumination31—just until the structure of interest is properly  
illuminated. Keeping the incident angle as high as possible limits out-of-focus excitation above the target structure,  
which is particularly critical for DNA-PAINT, as free imager strands in solution increase background and therefore affect  
imaging quality adversely.

45| In the device manager, adjust the ‘Readout Mode’ to the frequency with the lowest readout noise possible for the  
currently selected integration time. This is usually the lowest frequency at which the readout time does not exceed  
the exposure time. The readout time will be displayed in ‘ReadoutTime’ and should be shorter than the ‘Exposure’ time.  
Please double-check that the field ‘ActualInterval-ms’, which denotes the true duration between two frames, does not  
exceed the exposure time.

46| Click on ‘Multi-D-Acq.’ in the main window to open the ‘Multi-Dimensional Acquisition’ window. Activate ‘Time points’ 
and set the ‘Number’ to the number of frames to be acquired—e.g., 7,500 for in vitro samples and 15,000 for in situ samples. 
These exemplar numbers for total acquisition frames are suggestions for initial experiments and may have to be adjusted  
according to the specific experiment. For a detailed discussion of optimal acquisition time, refer to Nieuwenhuizen et al.16 
and respective sections in the introduction of this protocol.

47| Set the interval to ‘0’ and ‘ms’. Set ‘Acquisition Order’ to ‘Time’. Activate ‘Save images’ and set a destination filename and folder.

48| Select ‘Acquire!’ to start the acquisition. A live image will pop up. The progress of the acquisition can be followed  
on the upper left corner.
? TROUBLESHOOTING

49| (Optional) Multiplexed image acquisition. There are two methods for performing multiplexed target acquisition with  
DNA-PAINT. Spectral multiplexing (option A) uses spectrally distinct fluorophores, whereas Exchange-PAINT multiplexing 
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(option B) uses (typically) the same fluorophore attached to orthogonal DNA species that are sequentially supplied to the 
sample. With Exchange-PAINT, only one species is present in the imager buffer in each multiplexing round, and it will be 
washed out afterward. Option A provides a relatively fast workflow for imaging multiple targets by imaging in multiple emis-
sion channels. Option B has almost no limitation in multiplexing but requires a fluid exchange system. In addition, option B 
provides the capability of using the most favorable fluorophore for all targets. Refer to Supplementary Table 7 for a list of 
dye recommendations for DNA-PAINT.
(A) Spectral multiplexing
	 (i) �Perform Steps 34–48 for the first fluorophore. 

 CRITICAL STEP To reduce photodamage, start acquisition with the dye that has the longest excitation wavelength, 
and then proceed to those with shorter wavelengths.

	 (ii) �After acquisition of the first imager species, change the laser line and the filter set on the microscope to match the 
next wavelength.

	 (iii) �Click on ‘Live’ in the main window of µManager and adjust the TIRF angle if necessary.
	 (iv) �Adjust the file name in the ‘Multi-Dimensional Acquisition’ window.
	 (v) �Select ‘Acquire!’ to start a new acquisition.
	 (iv) �(Optional) Repeat the procedure for any other spectrally distinct imager species in solution.
(B) Exchange multiplexing
	 (i) �Perform Steps 34–48 to acquire a movie for the first imager species.
	 (ii) �Click on ‘Live’ in the main window and adjust the contrast so that individual blinking events are visible. Deselect  

‘Autostretch’. It is important to keep the contrast to determine when all imagers are washed out.
	 (iii) �Apply several washing steps while observing the ‘Live/Snap’ window until no more blinking events are visible.  

One washing step consists of filling the chamber by adding exchange buffer (for in vitro imaging use ~180 µl,  
and for in situ imaging use 1 ml) to the inlet and then removing the same volume from the outlet. For in situ  
imaging a total of ~15 ml and for in vitro imaging a total of ~1 ml of exchange buffer will be needed per  
exchange round. 
 CRITICAL STEP Do not remove all liquid from the chamber; it should never dry out. Perform liquid exchange slowly 
to avoid introducing air bubbles into the chamber or disturbing the sample. 
? TROUBLESHOOTING

	 (iv) �After washing, introduce a new imager solution into the chamber. For in vitro samples, simply pipette the required 
amount into the chamber and remove the same amount from the outlet. For in situ samples, empty the inlet tubing  
by disconnecting the empty syringe and pumping air through it. Connect a new 2-ml syringe with a new imager  
solution and fill the chamber.

	 (v) �While introducing the new imager, the ‘Live/Snap’ window should show reappearing blinking events.
	 (vi) �Adjust the filename in the ‘Multi-Dimensional Acquisition’ window.
	 (vii) �Select ‘Acquire!’ to start a new acquisition.
	(viii) �(Optional) Repeat the procedure for subsequent imaging rounds.

Image reconstruction ● TIMING 5–30 min
50| Identification and fitting of single-molecule spots. In ‘Picasso: Localize’, open a movie file by dragging the file into  
the window or by selecting ‘File’ > ‘Open’. If the movie is split into multiple µManager .tif files, open only the first file.  
Picasso will automatically detect the remaining files according to their file names.

51| Adjust the image contrast (select ‘View’ > ‘Contrast’) so that the single-molecule spots are clearly visible.

52| To adjust spot identification and fit parameters, open the ‘Parameters’ dialog (select ‘Analyze’ > ‘Parameters’).

53| In the ‘Identification’ group, set the ‘Box side length’ to the rounded integer value of 6 × σ + 1, where σ is the standard 
deviation of the PSF. In an optimized microscope setup, σ is one pixel, and the respective ‘Box side length’ should be set to 7.  
The value of ‘Min. net gradient’ specifies a minimum threshold above which spots should be considered for fitting. The net 
gradient value of a spot is roughly proportional to its intensity, independent of its local background. By checking ‘Preview’, 
the spots identified with the current settings will be marked in the displayed frame. Adjust ‘Min. net gradient’ to a value at 
which only spots are detected (no background).

54| In the ‘Photon conversion’ group, adjust ‘EM Gain’, ‘Baseline’, ‘Sensitivity’ and ‘Quantum Efficiency’ according to your 
camera specifications and the experimental conditions. Set ‘EM Gain’ to 1 for conventional output amplification. ‘Baseline’ is 
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the average dark camera count. ‘Sensitivity’ is the conversion factor (electrons per analog-to-digital (A/D) count) and  
‘Quantum Efficiency’ should be set according to the average emission wavelength.
 CRITICAL STEP These parameters are critical to converting camera counts to photons correctly. The quality of the upcom-
ing maximum likelihood fit strongly depends on a Poisson photon noise model, and thus on the absolute photon count.

For simulated data, generated with ‘Picasso: Simulate’ as described in Box 3 and Figure 7, set the parameters as follows:  
‘EM Gain’ = 1, ‘Baseline’ = 0, ‘Sensitivity’ = 1, ‘Quantum Efficiency’ = 1.

55| From the menu bar, select ‘Analyze’ > ‘Localize (Identify & Fit)’ to start spot identification and fitting in all movie 
frames. The status of this computation is displayed in the window’s status bar. After completion, the fit results will be saved 
in a new file in the same folder as the movie, in which the filename is the base name of the movie file with the extension 
‘_locs.hdf5’. Furthermore, information about the movie and analysis procedure will be saved in an accompanying file with  
the extension ‘_locs.yaml’; this file can be inspected using a text editor.

56| Rendering of the super-resolution image: In ‘Picasso: Render’, open a movie file by dragging a localization file (ending 
with ‘.hdf5’) into the window or by selecting ‘File’ > ‘Open’. The super-resolution image will be rendered automatically.  
A region of choice can be zoomed into by a rectangular selection using the left mouse button. The ‘View’ menu contains 
more options for zooming and panning.

57| (Optional) Adjust rendering options by selecting ‘View’ > ‘Display Settings’. The field ‘Oversampling’ defines the number 
of super-resolution pixels per camera pixel. The contrast settings ‘Min. Density’ and ‘Max. Density’ define at which number of 
localizations per super-resolution pixel the minimum and maximum color of the colormap should be applied.

58| (Optional) For multiplexed image acquisition, open HDF5 localization files from other channels subsequently.  
Alternatively, drag and drop all HDF5 files to be displayed simultaneously.

Image post-processing: drift correction ● TIMING seconds to minutes
59| Picasso offers two procedures to correct for drift: an RCC algorithm66 (option A), and use of specific structures  
in the image as drift markers23 (option B). Although option A does not require any additional sample preparation,  
option B depends on the presence of either fiducial markers or inherently clustered structures in the image. On the other 
hand, option B often supports more precise drift estimation and thus allows for higher image resolution. To achieve the  
highest possible resolution (ultra-resolution), we recommend consecutive applications of option A and multiple rounds of  
option B. The drift markers for option B can be features of the image itself (e.g., protein complexes or DNA origami) or  
intentionally included markers (e.g., DNA origami or gold nanoparticles). When using DNA origami as drift markers, the  
correction is typically applied in two rounds: first, with whole DNA origami structures as markers, and, second, using  
single DNA-PAINT binding sites as markers. In both cases, the precision of drift correction strongly depends on the  
number of selected drift markers.
(A) Redundant cross-correlation drift correction
	 (i) �In ‘Picasso: Render’, select ‘Postprocess’ > ‘Undrift by RCC’.
	 (ii) �A dialog will appear asking for the segmentation parameter. Although the default value, 1,000 frames, is a sensible 

choice for most movies, it might be necessary to adjust the segmentation parameter of the algorithm, depending on 
the total number of frames in the movie and the number of localizations per frame66. A smaller segment size results in 
better temporal drift resolution but requires a movie with more localizations per frame.

	 (iii) �After the algorithm finishes, the estimated drift will be displayed in a pop-up window and the display will show the 
drift-corrected image.

(B) Marker-based drift correction
	 (i) �In ‘Picasso: Render’, pick drift markers as described in Steps 61–64. Use the ‘Pick similar’ option (Step 65) to  

automatically detect a large number of drift markers similar to a few manually selected ones. 
 CRITICAL STEP If the structures used as drift markers have an intrinsic size larger than the precision of individual 
localizations (e.g., DNA origami, large protein complexes), it is critical to select a large number of structures.  
Otherwise, the statistic for calculating the drift in each frame (the mean displacement of localization to the  
structure’s center of mass) is not valid.

	 (ii) �Select ‘Postprocess; > ‘Undrift from picked’ to compute and apply the drift correction.

60| (Optional) Save the drift-corrected localizations by selecting ‘File’ > ‘Save localizations’.
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Picking of regions of interest ● TIMING 5–30 min
61| Manual selection. Open ‘Picasso: Render’ and load the localization HDF5 file to be processed.

62| Switch the active tool by selecting ‘Tools’ > ‘Pick’. The mouse cursor will now change to a circle.

63| Set the size of the pick circle by adjusting the ‘Diameter’ field in the tool settings dialog (‘Tools’ > ‘Tools Settings’).

64| Pick regions of interest using the circular mouse cursor by clicking the left mouse button. All localizations within the 
circle will be selected for further processing.

65| (Optional) Automated region of interest selection. Select ‘Tools’ > ‘Pick similar’ to automatically detect and pick structures 
that have similar numbers of localizations and RMS deviation (RMSD) from their center of mass than already-picked struc-
tures. The upper and lower thresholds for these similarity measures are the respective standard deviations of already-picked 
regions, scaled by a tunable factor. This factor can be adjusted using the field ‘Tools’ > ‘Tools Settings’ > ‘Pick similar ± 
range’. To display the mean and standard deviation of localization number and RMSD for currently picked regions, select ‘View’ 
> ‘Show info’ and click ‘Calculate info below’.

66| (Optional) Exporting of pick information. All localizations in picked regions can be saved by selecting ‘File’ > ‘Save picked 
localizations’. The resulting HDF5 file will contain a new integer column ‘group’ indicating to which pick each localization is 
assigned.

67| (Optional) Statistics about each pick region can be saved by selecting ‘File’ > ‘Save pick properties’. The resulting  
HDF5 file is not a localization file. Instead, it holds a data set called ‘groups’ in which the rows show statistical values  
for each pick region.

68| (Optional) The picked positions and diameter itself can be saved by selecting ‘File’ > ‘Save pick regions’. Such saved pick 
information can also be loaded into ‘Picasso: Render’ by selecting ‘File’ > ‘Load pick regions’.

Additional post-processing steps
69|Depending on the experimental goals, a variety of post-processing steps may be used. To filter localizations based on 
their properties, for example to remove localizations below a certain photon threshold, use option A. For investigating the 
statistics of DNA-PAINT binding kinetics and how to count DNA-PAINT binding sites with qPAINT22, use options B and C,  
respectively. Option D describes the procedure to generate an average image of multiple structures. Finally, option E  
describes the procedure to align images from multiplexed experiments.
(A) Filtering of localizations ● TIMING 5–10 min
	 (i) �Open a localization HDF5 file in ‘Picasso: Filter’ by dragging it into the main window or by selecting ‘File’ > ‘Open’.  

The displayed table shows the properties of each localization in rows. Each column represents one property (e.g.,  
coordinates, number of photons); see the Supplementary Manual for details.

	 (ii) �To display a histogram from values of one property, select the respective column in the header and select ‘Plot’ > 
‘Histogram’ (Ctrl + h). 2D histograms can be displayed by selecting two columns (press Ctrl to select multiple columns) 
and then selecting ‘Plot’ > ‘2D Histogram’ (Ctrl + d).

	 (iii) �Left-click and hold the mouse button down to drag a selection area in a 1D or 2D histogram. The selected area will be 
shaded in green, as shown in Supplementary Figure 5b,c. Each localization event with histogram properties outside 
the selected area is immediately removed from the localization list.

	 (iv) �Save the filtered localization table by selecting ‘File’ > ‘Save’.
(B) Analysis of blinking kinetics ● TIMING 5–60 min
	 (i) �In ‘Picasso: Render’, pick regions of interest as described in Steps 61–65.
	 (ii) �Select ‘View’ > ‘Show info’.
	 (iii) �In the opened dialog, click ‘Calculate info below’. The mean and standard deviation per pick of several values will be 

calculated and displayed. The ‘Length’ row describes the blinking ‘ON’ time (τb) and the ‘Dark time’ row describes the 
blinking ‘OFF’ time (τd).

	 (iv) �Click ‘Histograms’ to open a new window showing histograms for the picked region’s kinetics.
	 (v) �(Optional) Individual values for each picked region can be obtained by exporting the data. Select ‘File’ > ‘Save  

pick properties’. The saved HDF5 file will contain a data set called ‘groups’, in which each row corresponds to one  
pick region.
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(C) Counting of molecule numbers with qPAINT ● TIMING 5–60 min
	 (i) �In ‘Picasso: Render’, pick calibration regions as described in Steps 61–64. Typically, calibration regions are regions with 

a known number of binding sites. Do not use the option ‘Pick similar’ (Step 65), as this may bias the calibration.
	 (ii) �Select ‘View’ > ‘Show info’ and click ‘Calculate info below’.
	 (iii) �Set ‘# Units per pick’ to the number of units to which the counting should be calibrated. Typically, one unit is equal  

to one DNA-PAINT binding site, but other user-defined units might be suitable too. This could, i.e., be useful in the 
case in which calibration is performed on single antibodies, which can carry multiple docking strands for protein  
quantification using qPAINT. The final counting result will be reported in number of units. For example, if the  
calibration regions contain 12 binding sites and the counting result should be reported in ‘number of binding sites’, 
then ‘# Units per pick’ should be to be set to 12.

	 (iv) �Click ‘Calibrate influx’ for an estimation of the influx rate from the calibration regions kinetics. The influx rate will  
be displayed in the respective field. As an alternative to the experimental calibration, the influx rate (ξ) can be  
theoretically calculated via ξ = kon × c if the ON rate (kon) and imager concentration (c) are known. In that case,  
enter the influx rate manually into the respective field.

	 (v) �Select ‘Tools’ > ‘Clear picks’ to remove the calibration pick selections.
	 (vi) �Pick structures of interest (Steps 61–65) from which the unknown number of units should be determined.
	 (vii) �In the ‘Info’ dialog, click ‘Calculate info below’. The mean number of units per picked region will be displayed in the ‘# 

Units’ row, as calculated from the currently displayed influx rate.
	(viii) �(Optional) The individual number of units for each picked region can be obtained by exporting pick property data. 

Select ‘File’ > ‘Save pick properties’. The saved HDF5 file will contain a data set called ‘groups’, which holds statistics 
about each pick region as rows, including a column for the unit number (‘n_units’).

(D) Particle averaging ● TIMING 10–30 min
	 (i) �In ‘Picasso: Render’, pick structures to be averaged as in Steps 61–65.
	 (ii) �Save the picked localizations by selecting ‘File’ > ‘Save picked localizations’.
	 (iii) �Load the resulting file with picked localizations into ‘Picasso: Average’ by selecting ‘File’ > ‘Open’ or dragging and  

dropping it into the window.
	 (iv) �‘Picasso: Average’ will immediately perform a translational alignment of the picked structures and display an average 

image. Rotational and refined translational alignment will follow in the next steps.
	 (v) �Select ‘Process’ > ‘Parameters’ and adjust the ‘Oversampling’ parameter. We recommend choosing the highest number 

at which the average image still appears smooth. High oversampling values result in substantial computational time. 
Hence, it might be useful to first use low oversampling to generate a less-refined average image and perform a second 
averaging step with higher oversampling for optimized resolution.

	 (vi) �Adjust the number of average iterations in the ‘Iterations’ field. In most cases, a value of 10 is more than sufficient.  
If you are unsure about the computational time of the process, choose one iteration as a starting point. More  
iterations can be added later by repeating the processing steps. After a certain number of iterations, the average  
image will converge, meaning that it will not change with more iterations.

	 (vii) �Select ‘Process’ > ‘Average’ to perform particle averaging with the current oversampling for the set number of  
iterations. This step can be repeated with different settings. The program will use the current average image  
as a starting point.

	(viii) �Once the average image has converged, save the transformed localizations by selecting ‘File’ > ‘Save’. The resulting 
HDF5 localization file contains the aligned localizations in the center of the movie dimensions. It can be loaded like 
any other HDF5 localization file into ‘Picasso: Render’.

(E) Aligning of channels from multiplexed experiments ● TIMING 5–10 min
	 (i) �To align images from multiplexed data acquisition, the images need to share some features as reference points.  

Such reference features can be the cell shape for in situ images (typically, background is higher inside the cell)  
or overlapping clusters (for example, on the same DNA origami). If alignment results are ambiguous or not satisfying 
because of the lack of inherent reference features, drift or alignment markers should be included and imaged in  
all channels.

	 (ii) �In ‘Picasso: Render’ display all HDF5 localization files to be aligned.
	 (iii) �(Optional) If the reference features are too weak to create proper alignment, they can be selected manually,  

as described in Steps 61–65. Ensure that within a picked region the reference structures of all channels are included.
	 (iv) �Select ‘Postprocess’ > ‘Align’.
	 (v) �(Optional) Export the aligned localizations by selection ‘File’ > ‘Save localizations’.

? TROUBLESHOOTING
Troubleshooting advice can be found in Table 1.
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Table 1 | Troubleshooting table.

Steps Problem Possible reason Solution

Sample preparation

Step 17 There is no band  
visible on the gel

Depending on the used final scaffold 
concentration, the bands can  
appear very faint on the blue-light 
transilluminator table and seem  
difficult to excise

To improve brightness of the sample band, use a more  
sensitive DNA stain such as SYBR Gold, or increase scaffold 
concentration

The structure does 
not fold

Thermal gradients have an important 
role during the assembly process of 
DNA nanostructures. However, the 
rectangle 2D origami design shows 
extremely robust folding behavior and 
forms with high yield within ~75 min

Different temperature gradients between 15 and 72 h  
can be used to improve folding performance. Prepare fresh 
staple stocks for the origami structure with particular focus 
on correct magnesium concentration and staple excess

Step 
18A(ix), 
18B(viii)

There are not 
enough DNA origami 
structures on the 
surface

Depending on the purification 
method, different origami concentra-
tions are obtained—e.g., the size of 
the excised gel band will influence 
the concentration after the Freeze  
‘N Squeeze column purification step

Compensate for this by incubating with a higher origami  
concentration and/or increased incubation time. 
Concentration adjustment can be estimated by counting the 
number of targets on the surface and interpolating to the 
desired density. A good sample density can be achieved by 
incubation with 125–500 pM of origami. Typical concentra-
tions after gel purification are between 1 and 2 nM, and 
those after PEG purification are approximately 8–10 nM. 
Alternatively, the DNA origami solution can be incubated 
longer (up to 45 min)

Step 
19A(viii), 
19B(v)

After purification, 
there still seem to 
be free DNA strands 
in solution

The DNA strands might not be 
completely filtered out by the spin 
columns, which are optimized for 
protein concentration

For further purification of DNA-labeled antibodies, use  
size-exclusion column chromatography to remove the free 
DNA (with a Superdex 75/200)

Not enough DNA 
strands are attached 
to the antibodies

Not enough cross-linker or DNA  
was used

For more DNA handles attached to the antibodies, use larger 
excess of cross-linker (40×) and DNA (30×). However, please note 
that an increased DNA-to-antibody ratio might lead to reduced 
binding affinity of antibodies or increased off-target binding

Data acquisition

Step 41 Poor data quality Laser power not adjusted to sample To achieve the best possible data quality, it is important to 
extract the largest possible number of photons from a single 
binding (blinking) event of the fluorophores. A good indicator of 
a suitable laser power setting can be estimated by measuring 
the bright time versus laser power. Increase laser power until 
the bright time decreases. What happens is that imager strands 
start to bleach while they are still bound to docking strands. 
This should be the upper limit of your laser power setting. 
When a laser power meter is available, a good reference value 
for power densities in DNA-PAINT experiments using, i.e., Cy3B 
as dye and 561-nm laser excitation is 1–6 kW/cm2

Step 42 The focal plane is 
difficult to find

Focusing was not performed in  
bright-field mode, or the immersion 
oil was not in contact with the  
cover glass.

For cellular samples, focusing should be performed in  
bright-field. For DNA nanostructures, the immersion oil on 
the objective should touch the cover glass; use oblique 
illumination and then slowly raise the objective until the 
surface of the cover glass is reached. Monitor the approach 
in ‘Live’ mode. Reaching the cover glass will be visible via 
an increase in fluorescence and appearance of diffraction-
limited blinking spots. Add fluorescent beads that have 
increased brightness to find the focal plane, if necessary

(continued)
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● TIMING
Steps 1–5, design of DNA nanostructures: 1 h
Steps 6–9, folding of DNA nanostructures: 6–7 h
Steps 10–17, purification of DNA nanostructures: ~3.5 h
Step 18, preparation of DNA origami for DNA-PAINT imaging: 45 min
Step 19A, preparation of DNA-labeled antibodies using maleimide-PEG2-succinimidyl ester: 1 d and 1 h
Step 19B, labeling via DBCO-sulfo-NHS ester: 4 h
Steps 20–33, immunofixation of cells: 2.5 d
Steps 34–49, data acquisition: 10 min to 10 h; for each multiplexing round ~20 min–2 h
Steps 50–58, image reconstruction: 5–30 min
Steps 59 and 60, drift correction: seconds to minutes
Steps 61–68, picking of regions of interest: 5–30 min
Step 69A, filtering of localizations: 5–10 min
Step 69B, analysis of blinking kinetics with qPAINT: 5–60 min
Step 69C, counting of molecule numbers with qPAINT: 5–60 min
Step 69D, particle averaging: 10–30 min
Step 69E, aligning of channels for multiplexed experiments: 5–10 min
Box 1, construction of a fluid exchange chamber for in situ imaging: 30 min
Box 2, ultra-resolution imaging: ~7 h
Box 3, in silico simulation of DNA-PAINT: 10–60 min

ANTICIPATED RESULTS
Examples of single-color DNA-PAINT super-resolution images can be found in Figure 1. Panel b presents an image of a DNA 
origami with a three-by-four grid of binding sites, as designed with ‘Picasso: Design’. Measured distances between individual 
binding sites are in good agreement with the designed origami. Panels d and e show a DNA-PAINT image of microtubules  
in situ, immunolabeled with primary and secondary antibodies. Hollow microtubule structures, observed here as two parallel 
lines because of the 2D projection, are characteristic for a high labeling density and localization precision.

Expected results for multiplexed DNA-PAINT experiments by Exchange-PAINT are shown in Figure 2. Panels d, e and f show 
in vitro DNA origami imaged with multiple ‘Exchange’ rounds before (d) and after (e,f) alignment. The image after alignment 
shows that the DNA nanostructure is in good agreement with the designed pattern of binding sites. In situ Exchange-PAINT 
images of microtubules and Tom20, which localizes to mitochondria, are shown in panel g. The inset in panel g shows gold 
particles imaged in both rounds and demonstrates the alignment steps for the two images. The gold particles colocalize after 
the alignment procedure, and the different channels do not comprise any cross talk between them.

Results for counting DNA-PAINT binding sites via quantitative PAINT (qPAINT) can be found in Figure 3. Visual inspection 
of individual origami structures shows they match the predicted binding sites from the qPAINT analysis.

Expected results for ultra-resolution imaging, including the intermediate steps for drift correction and a final image from averaging 
multiple structures, can be seen in Figure 4. Key features of a successful ultra-resolution experiment are very high NeNA localization 
precision (~1 to 1.5 nm) and the ability to visually separate individual binding sites spaced 5 nm apart on the origami structures.

Table 1 | Troubleshooting table (continued).

Steps Problem Possible reason Solution

Step 48 The sample drifts in 
xy and/or focus is 
lost during image 
acquisition

Setup not equilibrated Before image acquisition, allow the sample to ‘equilibrate’ 
on the microscope for 5–15 min. Adjust room temperature to 
maintain a constant ambient temperature to avoid additional 
thermal drift of microscope and stage components

Step 
49B(iii)

The imager strands 
are difficult to  
wash away

Cellular samples are highly cross-
linked through the fixation process. 
Imager strands might be trapped in 
the cross-linked network

We recommend incubating with the washing solution for  
3 min so that the imager strands can diffuse into the  
large reservoir. In addition, washing with gentle flow  
can be effective

Box 3, 
step 6

The simulation of a 
DNA-PAINT data set 
takes a long time

The time required to simulate data 
sets is dependent on the number of 
structures, imager concentration, 
frames and image size

As computation time increases with image size, it is  
recommended to avoid exceeding an image size of  
64 × 64 pixels. A simulation with the standard settings 
should take <1 min on the described analysis computer
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Note: Any Supplementary Information and Source Data files are available in the 
online version of the paper.
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